summaryrefslogtreecommitdiff
path: root/dev-embedded/xa/xa-2.3.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/xa/xa-2.3.13.ebuild')
-rw-r--r--dev-embedded/xa/xa-2.3.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-embedded/xa/xa-2.3.13.ebuild b/dev-embedded/xa/xa-2.3.13.ebuild
new file mode 100644
index 000000000000..5e9388a99088
--- /dev/null
+++ b/dev-embedded/xa/xa-2.3.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="High-speed, two-pass portable 6502 cross-assembler"
+HOMEPAGE="https://www.floodgap.com/retrotech/xa/"
+SRC_URI="https://www.floodgap.com/retrotech/xa/dists/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.10-Makefile.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${ED}"/usr install
+ einstalldocs
+}