summaryrefslogtreecommitdiff
path: root/dev-embedded/urjtag/files/urjtag-2021.03-fix-python-setup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/urjtag/files/urjtag-2021.03-fix-python-setup.patch')
-rw-r--r--dev-embedded/urjtag/files/urjtag-2021.03-fix-python-setup.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-embedded/urjtag/files/urjtag-2021.03-fix-python-setup.patch b/dev-embedded/urjtag/files/urjtag-2021.03-fix-python-setup.patch
new file mode 100644
index 000000000000..c6206fefee2e
--- /dev/null
+++ b/dev-embedded/urjtag/files/urjtag-2021.03-fix-python-setup.patch
@@ -0,0 +1,14 @@
+Subject: [PATCH] python: replace distutils with setuptools
+
+distutils is deprecated for sometime and it was removed in python 3.12.
+
+--- a/bindings/python/setup.py.in 2018-03-24 20:27:41.000000000 +0800
++++ b/bindings/python/setup.py.in 2023-08-06 10:31:12.932358441 +0800
+@@ -1,6 +1,6 @@
+ # python extension setup script for urjtag
+
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+
+ libraries = ['urjtag']
+ libraries.extend( w.replace('-l', '') for w in "@LIBFTDI_LIBS@ @FTD2XXLIB@ @LIBUSB_LIBS@ @LIBINTL@".split() if w.replace('-l', '') not in libraries )