summaryrefslogtreecommitdiff
path: root/dev-embedded/srecord/srecord-1.64.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/srecord/srecord-1.64.ebuild')
-rw-r--r--dev-embedded/srecord/srecord-1.64.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-embedded/srecord/srecord-1.64.ebuild b/dev-embedded/srecord/srecord-1.64.ebuild
new file mode 100644
index 000000000000..beccea452409
--- /dev/null
+++ b/dev-embedded/srecord/srecord-1.64.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="A collection of powerful tools for manipulating EPROM load files"
+HOMEPAGE="http://srecord.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="dev-libs/libgcrypt:0"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-apps/groff
+ test? ( app-arch/sharutils )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.57-libtool.patch )
+
+src_prepare() {
+ default
+
+ cp etc/configure.ac "${S}"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}