summaryrefslogtreecommitdiff
path: root/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0-r1.ebuild')
-rw-r--r--dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0-r1.ebuild b/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..85ff04fa53c9
--- /dev/null
+++ b/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Simple tool for uploading files to the filesystem of an ESP8266 running NodeMCU"
+HOMEPAGE="https://github.com/kmpm/nodemcu-uploader"
+SRC_URI="https://github.com/kmpm/nodemcu-uploader/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/pyserial-3.4[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # https://bugs.gentoo.org/796422
+ sed -i -e 's:description-file:description_file:' setup.cfg || die
+
+ distutils-r1_src_prepare
+}