summaryrefslogtreecommitdiff
path: root/dev-embedded/libftdi/libftdi-1.5-r7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/libftdi/libftdi-1.5-r7.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-1.5-r7.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-embedded/libftdi/libftdi-1.5-r7.ebuild b/dev-embedded/libftdi/libftdi-1.5-r7.ebuild
index 4b8db8a33ade..36bf10ce1a9d 100644
--- a/dev-embedded/libftdi/libftdi-1.5-r7.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.5-r7.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+MY_P="${PN}1-${PV}"
PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1
-MY_P="${PN}1-${PV}"
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
else
SRC_URI="https://www.intra2net.com/en/developer/${PN}/download/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
-
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
fi
@@ -23,8 +22,8 @@ HOMEPAGE="https://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python test tools"
-RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
RDEPEND="
virtual/libusb:1
@@ -45,6 +44,7 @@ PATCHES=(
"${FILESDIR}"/${P}-tests-no-cxx.patch
"${FILESDIR}"/${P}-cmake-cxx.patch
"${FILESDIR}"/${P}-py312.patch
+ "${FILESDIR}"/${P}-cmake4.patch
)
pkg_setup() {