summaryrefslogtreecommitdiff
path: root/dev-embedded/jal/jal-0.4.62-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/jal/jal-0.4.62-r1.ebuild')
-rw-r--r--dev-embedded/jal/jal-0.4.62-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-embedded/jal/jal-0.4.62-r1.ebuild b/dev-embedded/jal/jal-0.4.62-r1.ebuild
new file mode 100644
index 000000000000..92343e68b945
--- /dev/null
+++ b/dev-embedded/jal/jal-0.4.62-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A high-level language for Microchip PIC and Ubicom SX microcontrollers"
+HOMEPAGE="https://jal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jal/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.62-fix-incompatible-integer-to-pointer-clang16.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}