summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-2.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/esptool/esptool-2.3.1.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.3.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-embedded/esptool/esptool-2.3.1.ebuild b/dev-embedded/esptool/esptool-2.3.1.ebuild
deleted file mode 100644
index 3a5259cd84b3..000000000000
--- a/dev-embedded/esptool/esptool-2.3.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-2.5[${PYTHON_USEDEP}]"
-
-RESTRICT="test" # Uses a device connected to the serial port
-
-python_test() {
- ${EPYTHON} test/test_esptool.py || die
-}