summaryrefslogtreecommitdiff
path: root/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch')
-rw-r--r--dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch b/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch
new file mode 100644
index 000000000000..1d266b0bb113
--- /dev/null
+++ b/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch
@@ -0,0 +1,24 @@
+Bug: https://bugs.gentoo.org/900687
+Upstream patch: https://sourceforge.net/p/avarice/patches/41/
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -97,7 +97,7 @@
+
+ # Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h termios.h unistd.h])
++AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/stat.h sys/time.h termios.h unistd.h])
+
+ AC_CHECK_HEADERS([bfd.h], , [ac_found_bfd_h=no])
+
+@@ -142,6 +142,9 @@
+ AC_MSG_CHECKING([whether libbfd requires libdl])
+ AC_LINK_IFELSE(
+ [AC_LANG_SOURCE([#include <bfd.h>
++ #ifndef bfd_get_section_name
++ extern bfd_get_section_name(bfd *abfd, const char *name);
++ #endif
+ bfd *file;
+ int main(void) {
+ bfd_init();