summaryrefslogtreecommitdiff
path: root/dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild')
-rw-r--r--dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild b/dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild
new file mode 100644
index 000000000000..64676af3c7c1
--- /dev/null
+++ b/dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_COMMIT_HASH="abc8fca7499f44c725122881cd380a88c37abe0e"
+DESCRIPTION="Arduino private fork of dev-util/ctags"
+HOMEPAGE="https://github.com/arduino/ctags"
+SRC_URI="https://github.com/arduino/ctags/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ctags-${MY_COMMIT_HASH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20161123-gcc-unused-attribute.patch
+)
+
+src_configure() {
+ econf \
+ --disable-readlib \
+ --disable-etags \
+ --enable-tmpdir="${EPREFIX}"/tmp
+}
+
+src_install() {
+ # This package compiles into a "ctags" executable, but don't want to clash into
+ # actually legitimate ctags implementations.
+ mv ctags arduino-ctags
+ dobin arduino-ctags
+}