summaryrefslogtreecommitdiff
path: root/dev-dotnet/gnome-keyring-sharp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gnome-keyring-sharp')
-rw-r--r--dev-dotnet/gnome-keyring-sharp/Manifest4
-rw-r--r--dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch10
-rw-r--r--dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r2.ebuild44
-rw-r--r--dev-dotnet/gnome-keyring-sharp/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-dotnet/gnome-keyring-sharp/Manifest b/dev-dotnet/gnome-keyring-sharp/Manifest
new file mode 100644
index 000000000000..4708137d4568
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/Manifest
@@ -0,0 +1,4 @@
+AUX gnome-keyring-sharp-1.0.2-monodoc-dir.patch 523 BLAKE2B 8626e9e335c0455231b5649a422f03e7a1473d6b955c022eeb69a13bb74ff781bc8d298af111b7189b75a75de20de71e9ee7981ed381a0f3c0f1ffdbae0d572b SHA512 b2da2dd6be235c766d9b99355cbc0ae778f58249ce2417f1b7ccd78e6e59d3c1d300ae199b6d3ea4333f996d7ede652eaccab6e59fbf3e30cac728e5a2c282ca
+DIST gnome-keyring-sharp-1.0.2.tar.gz 308244 BLAKE2B e21c5fe16b728d0239ea2f008b87068af5400b86e8276a13282a2606639f954e363d5e43871a11a41d852c04dec51de3fc9b6c7425b8775b06c2e434d9277849 SHA512 aad2fc1515a9d94971326a626d5957772927af5472afdbb517192e57c3928f32705c284b9599f350384a0c5d9cd7665b46677d550efe8506e27b485e2c40dcf0
+EBUILD gnome-keyring-sharp-1.0.2-r2.ebuild 1046 BLAKE2B 2c426362ebe2e6b6d9f09349249e54dc1874124cf33e85b67d3f74c266286dcbc2ae859e31cd200cbc059d5df92c7408095e686e3367745a481e416d4cf5509f SHA512 f3540a7a53bb829ad32b4a605e01dd84c5c6f346b67bc4aa94296c94de7d03e574c777a7ac26c3b183a411fb3076b3df34bec0b21ace9f72ab60a2171f404ab1
+MISC metadata.xml 354 BLAKE2B b5b550fdc8a6e58c232d67c1391e0399cb02a06f9821bad06861bb5d9217cb96a32606d96b26ce8e72203e47052fc3fb5f2f7fd1066e3cb95f0d151d1bbcfd0b SHA512 41e98fb855d1246a7cbf0b6f0c98a4415b6baa787e6981fbe7f579d970912b61492289764e52d1959d248b70ed8367ff3be8198e051ca4e5d72d729865b82ae4
diff --git a/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch b/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch
new file mode 100644
index 000000000000..71945c236635
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch
@@ -0,0 +1,10 @@
+diff -uNr gnome-keyring-sharp-1.0.1.old/docs/Makefile.am gnome-keyring-sharp-1.0.1/docs/Makefile.am
+--- gnome-keyring-sharp-1.0.1.old/docs/Makefile.am 2009-05-07 17:32:19.000000000 +0200
++++ gnome-keyring-sharp-1.0.1/docs/Makefile.am 2011-10-31 17:03:46.648191581 +0100
+@@ -1,5 +1,5 @@
+ if ENABLE_MONODOC
+-SOURCESDIR=$(libdir)/monodoc/sources
++SOURCESDIR=$(prefix)/lib/monodoc/sources
+ TARGETS=Gnome.Keyring.tree Gnome.Keyring.zip Gnome.Keyring.source
+ UPDATER = $(MONODOCER) -path:Gnome.Keyring $(UPDATE_ASSEMBLIES)
+ else
diff --git a/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r2.ebuild b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..8791bdb9d6af
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils mono-env
+
+DESCRIPTION="C# implementation of gnome-keyring"
+HOMEPAGE="http://www.mono-project.com/ https://github.com/mono/gnome-keyring-sharp"
+SRC_URI="http://www.go-mono.com/archive/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/mono-2.0
+ >=gnome-base/libgnome-keyring-2.30.0
+ || ( >=dev-dotnet/gtk-sharp-2.12.21 dev-dotnet/glib-sharp )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Disable building samples.
+ sed -i -e 's:sample::' "${S}"/Makefile.in || die "sed failed"
+
+ # Apply Fedora patches
+ epatch "${FILESDIR}/${PN}-1.0.2-monodoc-dir.patch"
+ eautoreconf
+}
+
+src_compile() {
+ # This dies without telling in docs with anything not -j1
+ # CSC=gmcs needed for https://bugs.gentoo.org/show_bug.cgi?id=250069
+ # Changed to CSC=mcs for mono-4 compatibility
+ emake -j1 CSC=mcs
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/dev-dotnet/gnome-keyring-sharp/metadata.xml b/dev-dotnet/gnome-keyring-sharp/metadata.xml
new file mode 100644
index 000000000000..0911b58ff2b2
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mono/gnome-keyring-sharp</remote-id>
+ </upstream>
+</pkgmetadata>