summaryrefslogtreecommitdiff
path: root/dev-dotnet/fantomas/fantomas-6.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/fantomas/fantomas-6.2.3.ebuild')
-rw-r--r--dev-dotnet/fantomas/fantomas-6.2.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-dotnet/fantomas/fantomas-6.2.3.ebuild b/dev-dotnet/fantomas/fantomas-6.2.3.ebuild
index 8b3b84d8a7a7..d1be8a007fb9 100644
--- a/dev-dotnet/fantomas/fantomas-6.2.3.ebuild
+++ b/dev-dotnet/fantomas/fantomas-6.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -253,6 +253,9 @@ src_unpack() {
}
src_prepare() {
+ dotnet-pkg_src_prepare
+
+ find "${S}" -type f -iname nuget.config -exec rm -v {} + || die
cat <<EOF > NuGet.config || die
<?xml version="1.0" encoding="utf-8"?>
<configuration>
@@ -268,8 +271,6 @@ EOF
ln -s "${WORKDIR}/fsharp-${FCS_COMMIT}" "${S}/.deps/${FCS_COMMIT}" || die
find "${S}/.deps/${FCS_COMMIT}/src" -type f \
-exec sed -e "s|FSharp.Compiler|Fantomas.FCS|g" -i {} + || die
-
- dotnet-pkg_src_prepare
}
src_configure() {