summaryrefslogtreecommitdiff
path: root/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild')
-rw-r--r--dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild b/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild
new file mode 100644
index 000000000000..627f525f470d
--- /dev/null
+++ b/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools mono-env eutils
+
+DESCRIPTION="D-Bus for .NET"
+HOMEPAGE="https://github.com/mono/dbus-sharp"
+SRC_URI="https://github.com/mono/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono
+ sys-apps/dbus"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS README"
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/gmcs/mcs/' configure.ac || die
+ eautoreconf
+}