summaryrefslogtreecommitdiff
path: root/dev-dotnet/coco
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/coco')
-rw-r--r--dev-dotnet/coco/Manifest2
-rw-r--r--dev-dotnet/coco/coco-2014.12.24-r4.ebuild37
-rw-r--r--dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-dotnet/coco/Manifest b/dev-dotnet/coco/Manifest
index 4e629ee139f6..315da7a87e47 100644
--- a/dev-dotnet/coco/Manifest
+++ b/dev-dotnet/coco/Manifest
@@ -1,4 +1,6 @@
+AUX coco-2014.12.24-Coco-csproj-net9.patch 375 BLAKE2B 64ddfcd523db8b881fc054a6a0c0cd8e4769e0fcb7d687b5ecc19c3f12d1b4d643bf10476e3bd9c7afc6653ef99f572bd8c87b538f535d7ef1946a0efbf916eb SHA512 883138813fccf3366e0ed7e54c608d98446c25102a6b0c65538a6e8ffded73f565e2940ee13e1539e73d089686996eb7fcd0b725fd06f61c692a725f0b926a1e
AUX coco-2014.12.24-Coco-csproj.patch 375 BLAKE2B 1acdf15002c0ca2aff84731c5fbc124acd751c842498a1e755dc14bbe5a95146c0675cf1fb2a7af6db7f97e31aca42c733ca05f8c7173c04eda6390658b3e561 SHA512 0879c975c30b555c150128fdc9aa51b2210af2fa6512097b4dd2a4352d1736239baa02116e554c888145c3856e302bcb56fb3643cd3508b8625f9f47f738f9e9
DIST coco-2014.12.24.tar.gz 37670 BLAKE2B acd2299e3452d4dac495a0a7f897694791b4abcc0dd7c243771fe8c7084cd9909110c655788844e11fbb576bd95e3596cb890c0ec930c3e4587fd3313082b5cb SHA512 d3b5af1b73b233a8c4b4572db8d65b1c1ffec36e455e4d5fadf1002125433551c833b9574ae03edbe2cd3978fedef41c85667fce82ff2d6ee155c16f778f970e
EBUILD coco-2014.12.24-r3.ebuild 746 BLAKE2B 836d7f37ff0ea533ec57950bbe7336e069a6e934fdcd7f972de38523664fea7a287b65b711d279ca21b1274db97b88c55d2df74abdc3dc753bc15125e2d227f8 SHA512 6a932207969e11c17645930e6172ba05b7571b87cb0f59aea73b0c11bc5fc2befcb3db06ba52af8b4d28d1693750c7dfb3268d3d29919c6cce6044109199e73b
+EBUILD coco-2014.12.24-r4.ebuild 730 BLAKE2B 8b58f7709ca5fceab3fae9262e0ff648ffc5b91d2804582ffd40f865a260bb62510b203001082f2816acc821a713d96a2ca10eff4dbd81952a67d2176b2c530d SHA512 b2035d6d0261923aa0ee5dcf4d3c435825e157b24bde18a97edb76191c6cf09084c88563228b8c1b389e635dcc54540427baac089abaf5d79cdabf41dd14b201
MISC metadata.xml 413 BLAKE2B b2aa9bf31ee00f8e566e236cf74bcb8f66ffba5e17f2d6d59cea01508e1dbdea6096c68af3aa0342035dd173987a7b2466d7ba78bf3ebb92121f026581c95c60 SHA512 465c0da3ea75035edba3f11725dad039b397dcce3e2fb66afcd52f585ed977500af1b2ee0e031ab815ce68ad097d8a4b4ae9a5d26087ec8316f704efd0463a88
diff --git a/dev-dotnet/coco/coco-2014.12.24-r4.ebuild b/dev-dotnet/coco/coco-2014.12.24-r4.ebuild
new file mode 100644
index 000000000000..d0c87d1f9f99
--- /dev/null
+++ b/dev-dotnet/coco/coco-2014.12.24-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT="9.0"
+NUGET_PACKAGES=""
+
+inherit dotnet-pkg
+
+DESCRIPTION="The compiler generator Coco/R for C#"
+HOMEPAGE="https://github.com/boogie-org/coco/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/boogie-org/${PN}.git"
+else
+ SRC_URI="https://github.com/boogie-org/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=( Coco.csproj )
+PATCHES=( "${FILESDIR}/coco-2014.12.24-Coco-csproj-net9.patch" )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
diff --git a/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch b/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch
new file mode 100644
index 000000000000..553c1ab0b011
--- /dev/null
+++ b/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj-net9.patch
@@ -0,0 +1,11 @@
+--- a/Coco.csproj
++++ b/Coco.csproj
+@@ -13,7 +13,7 @@
+
+ <PropertyGroup>
+ <OutputType>Exe</OutputType>
+- <TargetFrameworks>net6.0;net5.0;netcoreapp3.1</TargetFrameworks>
++ <TargetFrameworks>net9.0</TargetFrameworks>
+ <PackAsTool>true</PackAsTool>
+ <ToolCommandName>coco</ToolCommandName>
+ <GeneratePackageOnBuild>true</GeneratePackageOnBuild>