summaryrefslogtreecommitdiff
path: root/dev-debug/strace/strace-6.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/strace/strace-6.13.ebuild')
-rw-r--r--dev-debug/strace/strace-6.13.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-debug/strace/strace-6.13.ebuild b/dev-debug/strace/strace-6.13.ebuild
index d5b1de3c19a2..fe6ea78b288c 100644
--- a/dev-debug/strace/strace-6.13.ebuild
+++ b/dev-debug/strace/strace-6.13.ebuild
@@ -16,7 +16,7 @@ else
https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz
verify-sig? ( https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz.asc )
"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
fi
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/strace.asc
@@ -40,7 +40,6 @@ LIB_DEPEND="
DEPEND="
static? ( ${LIB_DEPEND} )
aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
"
RDEPEND="
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
@@ -87,11 +86,15 @@ src_configure() {
# Don't require mpers support on non-multilib systems. #649560
--enable-mpers=check
+ # We don't want to pin to exact linux-headers versions (bug #950309)
+ --enable-bundled=yes
+
$(use_enable static)
$(use_with unwind libunwind)
$(use_with elfutils libdw)
$(use_with selinux libselinux)
)
+
econf "${myeconfargs[@]}"
}