summaryrefslogtreecommitdiff
path: root/dev-debug/gdb/gdb-14.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/gdb/gdb-14.1-r1.ebuild')
-rw-r--r--dev-debug/gdb/gdb-14.1-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-debug/gdb/gdb-14.1-r1.ebuild b/dev-debug/gdb/gdb-14.1-r1.ebuild
index f9b8b1ba925b..6894ea21be93 100644
--- a/dev-debug/gdb/gdb-14.1-r1.ebuild
+++ b/dev-debug/gdb/gdb-14.1-r1.ebuild
@@ -134,6 +134,14 @@ src_prepare() {
# Avoid using ancient termcap from host on Prefix systems
sed -i -e 's/termcap tinfow/tinfow/g' \
gdb/configure{.ac,} || die
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # code relies on C++11, so make sure we get that selected
+ # due to Python 3.11 pymacro.h doing stuff to work around
+ # versioning mess based on the C version, while we're compiling
+ # C++ here, so we need to make it clear we're doing C++11/C11
+ # because Solaris system headers act on these
+ sed -i -e 's/-x c++/-std=c++11/' gdb/Makefile.in || die
+ fi
}
gdb_branding() {