summaryrefslogtreecommitdiff
path: root/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild')
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild50
1 files changed, 31 insertions, 19 deletions
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
index 52ddccc5c6ad..0fe6fc6285d1 100644
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="A library of routines for managing a database"
HOMEPAGE="https://fallabs.com/tokyocabinet/"
@@ -18,43 +18,55 @@ DEPEND="bzip2? ( app-arch/bzip2 )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/fix_rpath.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
+ default
+
sed -i \
-e "/ldconfig/d" \
-e "/DATADIR/d" Makefile.in || die
+
# cflags fix - remove -O2 at end of line and -fomit-frame-pointer
sed -i -e 's/-O3"$/"/' configure.in || die
sed -i -e 's/-fomit-frame-pointer//' configure.in || die
+
# flag only works on x86 derivatives, remove everywhere else
- if ! use x86 && ! use amd64; then sed -i -e 's/ -minline-all-stringops//' configure.in; fi
+ if ! use x86 && ! use amd64; then
+ sed -i -e 's/ -minline-all-stringops//' configure.in || die
+ fi
+
+ mv configure.{in,ac} || die
+
eautoreconf
}
src_configure() {
# we use the "fastest" target without the -O3
econf \
- $(use_enable debug) \
- $(use_enable bzip2 bzip) \
- $(use_enable zlib) \
- $(use_enable threads pthread) \
- --enable-off64 --enable-fastest
+ $(use_enable debug) \
+ $(use_enable bzip2 bzip) \
+ $(use_enable zlib) \
+ $(use_enable threads pthread) \
+ --enable-off64 \
+ --enable-fastest
+}
+
+src_test() {
+ emake -j1 check
}
src_install() {
emake DESTDIR="${D}" install
- if use examples; then
- insinto /usr/share/${PF}/example
- doins example/*
- fi
-
if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/*
+ dodoc -r doc/*
fi
-}
-src_test() {
- emake -j1 check
+ if use examples; then
+ docinto example
+ dodoc example/*
+ fi
}