summaryrefslogtreecommitdiff
path: root/dev-db/textsearch_ja/textsearch_ja-9.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/textsearch_ja/textsearch_ja-9.0.0.ebuild')
-rw-r--r--dev-db/textsearch_ja/textsearch_ja-9.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-db/textsearch_ja/textsearch_ja-9.0.0.ebuild b/dev-db/textsearch_ja/textsearch_ja-9.0.0.ebuild
new file mode 100644
index 000000000000..2fa5d4ea83b1
--- /dev/null
+++ b/dev-db/textsearch_ja/textsearch_ja-9.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="Integrated Full-Text-Search for Japanese language using morphological analyze"
+HOMEPAGE="http://textsearch-ja.projects.postgresql.org/index.html"
+SRC_URI="http://pgfoundry.org/frs/download.php/2943/textsearch_ja-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-text/mecab
+ >=dev-db/postgresql-7.4[server]" # pgmecab requires PGXS
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+}