summaryrefslogtreecommitdiff
path: root/dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild')
-rw-r--r--dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild b/dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild
index d094723adf0a..cea98af250c9 100644
--- a/dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild
+++ b/dev-db/sqlitebrowser/sqlitebrowser-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="A light GUI editor for SQLite databases"
HOMEPAGE="https://sqlitebrowser.org/"
@@ -18,7 +18,7 @@ fi
LICENSE="GPL-3+ MPL-2.0"
SLOT="0"
-IUSE="test"
+IUSE="sqlcipher test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -33,6 +33,7 @@ DEPEND="
>=dev-qt/qtwidgets-5.5:5
>=dev-qt/qtxml-5.5:5
>=x11-libs/qscintilla-2.8.10:=
+ sqlcipher? ( dev-db/sqlcipher )
"
BDEPEND="
@@ -61,7 +62,12 @@ src_configure() {
-DENABLE_TESTING=$(usex test)
-DFORCE_INTERNAL_QCUSTOMPLOT=OFF
-DFORCE_INTERNAL_QHEXEDIT=OFF
+ -Dsqlcipher=$(usex sqlcipher)
)
+ # https://bugs.gentoo.org/855254
+ append-flags -fno-strict-aliasing
+ filter-lto
+
cmake_src_configure
}