summaryrefslogtreecommitdiff
path: root/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlcipher/sqlcipher-3.4.2.ebuild')
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.4.2.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild b/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
index 8f299103e6af..1f5bdc481350 100644
--- a/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
+++ b/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils flag-o-matic ltprune multilib-minimal
+inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="Full Database Encryption for SQLite"
HOMEPAGE="https://www.zetetic.net/sqlcipher/"
@@ -41,12 +41,12 @@ src_prepare() {
eapply "${FILESDIR}/${P}-libressl-2.8.patch"
append-cflags -DSQLITE_HAS_CODEC
- eapply_user
+ default
eautoreconf
}
multilib_src_configure() {
- ECONF_SOURCE=${S} \
+ ECONF_SOURCE="${S}" \
econf \
--enable-fts3 \
--enable-fts4 \
@@ -60,6 +60,7 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
+
einstalldocs
}