summaryrefslogtreecommitdiff
path: root/dev-db/redis/files/redis-5.0.8-ppc-atomic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/redis/files/redis-5.0.8-ppc-atomic.patch')
-rw-r--r--dev-db/redis/files/redis-5.0.8-ppc-atomic.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-db/redis/files/redis-5.0.8-ppc-atomic.patch b/dev-db/redis/files/redis-5.0.8-ppc-atomic.patch
new file mode 100644
index 000000000000..61a4cc721eb1
--- /dev/null
+++ b/dev-db/redis/files/redis-5.0.8-ppc-atomic.patch
@@ -0,0 +1,19 @@
+diff --git a/src/Makefile b/src/Makefile
+index 4b2a31c..4ef853b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -77,6 +77,14 @@ FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
+ FINAL_LIBS=-lm
+ DEBUG=-g -ggdb
+
++ifneq (,$(filter powerpc ppc,$(uname_M)))
++ FINAL_LIBS+=-latomic
++else
++ifneq (,$(findstring ppc,$(uname_M)))
++ FINAL_LIBS+=-latomic
++endif
++endif
++
+ # Linux ARM needs -latomic at linking time
+ ifneq (,$(filter aarch64 armv,$(uname_M)))
+ FINAL_LIBS+=-latomic