summaryrefslogtreecommitdiff
path: root/dev-db/psqlodbc/psqlodbc-13.00.0000.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/psqlodbc/psqlodbc-13.00.0000.ebuild')
-rw-r--r--dev-db/psqlodbc/psqlodbc-13.00.0000.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/psqlodbc-13.00.0000.ebuild b/dev-db/psqlodbc/psqlodbc-13.00.0000.ebuild
new file mode 100644
index 000000000000..eb5492ff004f
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-13.00.0000.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="https://odbc.postgresql.org/"
+SRC_URI="https://ftp.postgresql.org/pub/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iodbc ssl threads"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+# No tests to run
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dodoc docs/*{html,jpg,txt}
+}