summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-14_beta2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-14_beta2.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-14_beta2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-db/postgresql/postgresql-14_beta2.ebuild b/dev-db/postgresql/postgresql-14_beta2.ebuild
index a9630c760e88..e6463312ebcb 100644
--- a/dev-db/postgresql/postgresql-14_beta2.ebuild
+++ b/dev-db/postgresql/postgresql-14_beta2.ebuild
@@ -135,14 +135,13 @@ src_configure() {
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
- econf \
+ local myconf="\
--prefix="${PO}/usr/$(get_libdir)/postgresql-${SLOT}" \
--datadir="${PO}/usr/share/postgresql-${SLOT}" \
--includedir="${PO}/usr/include/postgresql-${SLOT}" \
--mandir="${PO}/usr/share/postgresql-${SLOT}/man" \
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
- $(use_enable !alpha spinlocks) \
$(use_enable debug) \
$(use_enable threads thread-safety) \
$(use_with icu) \
@@ -161,7 +160,14 @@ src_configure() {
$(use_with xml libxml) \
$(use_with xml libxslt) \
$(use_with zlib) \
- $(use_enable nls)
+ $(use_enable nls)"
+ if use alpha || use riscv; then
+ myconf+=" --disable-spinlocks"
+ else
+ # Should be the default but just in case
+ myconf+=" --enable-spinlocks"
+ fi
+ econf ${myconf}
}
src_compile() {