summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-13.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-13.3.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-13.3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-db/postgresql/postgresql-13.3.ebuild b/dev-db/postgresql/postgresql-13.3.ebuild
index 85d7618669ca..4063b6442c59 100644
--- a/dev-db/postgresql/postgresql-13.3.ebuild
+++ b/dev-db/postgresql/postgresql-13.3.ebuild
@@ -91,6 +91,8 @@ pkg_setup() {
}
src_prepare() {
+ eapply "${FILESDIR}"/${PN}-13.3-riscv-spinlocks.patch
+
# Set proper run directory
sed "s|\(PGSOCKET_DIR\s\+\)\"/tmp\"|\1\"${EPREFIX}/run/postgresql\"|" \
-i src/include/pg_config_manual.h || die
@@ -159,7 +161,7 @@ src_configure() {
$(use_with xml libxslt) \
$(use_with zlib) \
$(use_enable nls)"
- if use alpha || use riscv; then
+ if use alpha; then
myconf+=" --disable-spinlocks"
else
# Should be the default but just in case