summaryrefslogtreecommitdiff
path: root/dev-db/pg-gvm/pg-gvm-22.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pg-gvm/pg-gvm-22.6.1-r1.ebuild')
-rw-r--r--dev-db/pg-gvm/pg-gvm-22.6.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/pg-gvm/pg-gvm-22.6.1-r1.ebuild b/dev-db/pg-gvm/pg-gvm-22.6.1-r1.ebuild
new file mode 100644
index 000000000000..96da716d298f
--- /dev/null
+++ b/dev-db/pg-gvm/pg-gvm-22.6.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="Greenbone Library for helper functions in PostgreSQL"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/pg-gvm"
+SRC_URI="https://github.com/greenbone/pg-gvm/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=dev-libs/libical-1.0.0:=
+ >=net-analyzer/gvm-libs-22.6
+"
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-db/postgresql-9.6:=[uuid]
+"
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}