summaryrefslogtreecommitdiff
path: root/dev-db/mysql/mysql-5.7.29-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql/mysql-5.7.29-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.7.29-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-db/mysql/mysql-5.7.29-r1.ebuild b/dev-db/mysql/mysql-5.7.29-r1.ebuild
index 1d1fd598dd93..a68c2ae2ff7c 100644
--- a/dev-db/mysql/mysql-5.7.29-r1.ebuild
+++ b/dev-db/mysql/mysql-5.7.29-r1.ebuild
@@ -26,11 +26,10 @@ HOMEPAGE="https://www.mysql.com/"
DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
LICENSE="GPL-2"
SLOT="5.7/18"
-IUSE="cjk client-libs cracklib debug experimental jemalloc latin1 libressl numa +perl profiling
+IUSE="cjk client-libs cracklib debug experimental jemalloc latin1 numa +perl profiling
selinux +server static static-libs systemtap tcmalloc test"
-# Tests always fail when libressl is enabled due to hard-coded ciphers in the tests
-RESTRICT="!test? ( test ) libressl? ( test )"
+RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( tcmalloc jemalloc )"
@@ -55,7 +54,6 @@ PATCHES=(
"${MY_PATCH_DIR}"/20007_all_cmake-debug-werror-5.7.patch
"${MY_PATCH_DIR}"/20009_all_mysql_myodbc_symbol_fix-5.7.10.patch
"${MY_PATCH_DIR}"/20018_all_mysql-5.7.29-without-clientlibs-tools.patch
- "${MY_PATCH_DIR}"/20018_all_mysql-5.7.29-fix-libressl-support.patch
"${MY_PATCH_DIR}"/20018_all_mysql-5.7.23-fix-grant_user_lock-a-root.patch
"${MY_PATCH_DIR}"/20018_all_mysql-5.7.23-round-off-test-values-for-same-output-on-all-architectures.patch
"${MY_PATCH_DIR}"/20018_all_mysql-5.7.25-fix-build-without-server.patch
@@ -91,12 +89,10 @@ COMMON_DEPEND="net-misc/curl:=
systemtap? ( >=dev-util/systemtap-1.3:0= )
tcmalloc? ( dev-util/google-perftools:0= )
client-libs? (
- !libressl? ( >=dev-libs/openssl-1.0.0:0=[${MULTILIB_USEDEP},static-libs?] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP},static-libs?] )
+ >=dev-libs/openssl-1.0.0:0=[${MULTILIB_USEDEP},static-libs?]
)
!client-libs? (
- !libressl? ( >=dev-libs/openssl-1.0.0:0= )
- libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/openssl-1.0.0:0=
)
"
DEPEND="${COMMON_DEPEND}
@@ -305,11 +301,6 @@ src_prepare() {
man/zlib_decompress.1 \
|| die
- if use libressl ; then
- sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
- "${S}/cmake/ssl.cmake" || die
- fi
-
sed -i 's~ADD_SUBDIRECTORY(storage/ndb)~~' CMakeLists.txt || die
}