summaryrefslogtreecommitdiff
path: root/dev-db/apgdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/apgdiff')
-rw-r--r--dev-db/apgdiff/Manifest2
-rw-r--r--dev-db/apgdiff/apgdiff-2.7.0-r1.ebuild (renamed from dev-db/apgdiff/apgdiff-2.7.0.ebuild)25
2 files changed, 6 insertions, 21 deletions
diff --git a/dev-db/apgdiff/Manifest b/dev-db/apgdiff/Manifest
index aede6bf47c4b..1adb2f91c7fd 100644
--- a/dev-db/apgdiff/Manifest
+++ b/dev-db/apgdiff/Manifest
@@ -1,3 +1,3 @@
DIST apgdiff-2.7.0-sources.tar.gz 365759 BLAKE2B 6a43bea29fa77a6a07b8599b150769e42480e656d7930faf56dd5db89a2281e10baee596e78d245411879ca99e143d3ebfb6144ea68b5d2f56f7f939004897dc SHA512 db52bcf5af78339ab08cd6a5225d7df9d55cf4eb1bcefaf9e9b12f8ac06f7babb2261ac92b7aa49a6f43a39f9e7894f4dea88b1b794f0a87681ab872c5d1d430
-EBUILD apgdiff-2.7.0.ebuild 1433 BLAKE2B 3ac7579885521423222c0ff2ecd96b8618e4765c9262c62244aec885b70b0ea8c8ae2ded2f14a7803766a2d679fe120da37067530ff6eccf5c98392049a1cacf SHA512 c658f97bd22e7428b0665b779b7ae9b696345a409d9078239845d946c320c5489623e8718d82113d0022feb916be1cc6dc29d8092f722c73b9435871a0e36299
+EBUILD apgdiff-2.7.0-r1.ebuild 939 BLAKE2B 31e53651d2b8f8b97c051947334325caea6533473af0c8b2d49f21153b346abf88eb4f6e362fcea84f273fde519355b05cdcdb2f38397b9ae659bd61d8ceba35 SHA512 72571bb4abd12449b6fce223c49c5ab3f9f0d4639a0555b6fdcd8cc6ac2abb814c1377a9d082599845f21676e17c56cedf2eccb87f5d1f7011bb392c6a63ec8a
MISC metadata.xml 306 BLAKE2B b185e2d5851452096cf420f322649f490cc5454c6d463c7c2d3e49f7b2de333996b37d1e1cbcc7bd8ed9a9fb25755a4ce65687031bbe2d2a83c97dc4ba9dfba2 SHA512 ba3044cadef74e5508c4a9bea6201c06674f0ff822201faf97c48f8112252b673b834ceca5889b9bcb6bd3cbd6745c149399b30fd420ecee3ef512edce021280
diff --git a/dev-db/apgdiff/apgdiff-2.7.0.ebuild b/dev-db/apgdiff/apgdiff-2.7.0-r1.ebuild
index 25a2bab6828c..8295ae9059f6 100644
--- a/dev-db/apgdiff/apgdiff-2.7.0.ebuild
+++ b/dev-db/apgdiff/apgdiff-2.7.0-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/fordfrog/apgdiff/archive/refs/tags/release_2.7.0.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild apgdiff-2.7.0.ebuild
-
-EAPI=7
+EAPI=8
JAVA_PKG_IUSE="doc source test"
MAVEN_ID="cz.startnet:apgdiff:2.7.0"
@@ -14,33 +11,21 @@ inherit java-pkg-2 java-pkg-simple
DESCRIPTION="A simple PostgreSQL diff tool that is useful for schema upgrades"
HOMEPAGE="https://github.com/fordfrog/apgdiff https://www.apgdiff.com/"
-SRC_URI="https://github.com/fordfrog/${PN}/archive/refs/tags/release_${PV}.tar.gz -> ${P}-sources.tar.gz"
+SRC_URI="https://github.com/fordfrog/${PN}/archive/release_${PV}.tar.gz -> ${P}-sources.tar.gz"
+S="${WORKDIR}/${PN}-release_${PV}"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:4.13.1 -> >=dev-java/junit-4.13.2:4
-# test? org.hamcrest:hamcrest-all:1.3 -> !!!artifactId-not-found!!!
-
DEPEND="
>=virtual/jdk-1.8:*
- ${CDEPEND}
test? (
dev-java/hamcrest-core:0
)
"
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${PN}-release_${PV}"
-
-JAVA_LAUNCHER_FILENAME="${PN}"
+RDEPEND=">=virtual/jre-1.8:*"
JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS="cz.startnet.utils.pgdiff.Main"