summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin16852 -> 16841 bytes
-rw-r--r--dev-cpp/asio/Manifest2
-rw-r--r--dev-cpp/asio/asio-1.34.0.ebuild54
-rw-r--r--dev-cpp/nlohmann_json/Manifest5
-rw-r--r--dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13-2.patch42
-rw-r--r--dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13.patch76
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.11.2-r1.ebuild70
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild65
-rw-r--r--dev-cpp/sol2/Manifest4
-rw-r--r--dev-cpp/sol2/files/sol2-3.5.0-catch-depend.patch16
-rw-r--r--dev-cpp/sol2/files/sol2-3.5.0-luajit-pkgconf.patch17
-rw-r--r--dev-cpp/sol2/sol2-3.5.0.ebuild66
12 files changed, 159 insertions, 258 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index b757937f2c16..17314fee0b66 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 920eb4815a59..dab0f2b77ec1 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,4 +1,6 @@
AUX asio-1.30.1-pkgconfig.patch 505 BLAKE2B d5c8d55444a47608f681dfbac9978edebb206b999aa7914b6d056bd18c252f001f58d53b587b2859c66495d6f8c3f74f252ddc9d7c25a8d37a394d843433f722 SHA512 b90f12054921913a6702863a731448e43635871e6fe1cb7baa80e5ad9487501704c634efe25592e661c999cafa61af2a4841add3221db28b1d29290eeea61446
+DIST asio-1-34-0.tar.gz 2845964 BLAKE2B 6b51544ead3c17a1ab35524b21e1ff51d38ae86a70622bc86c04678d882843f5f03c35363a7f0b23393fa688b6dd0600cec5c1a4812e273cca1813700c04f0ec SHA512 989e1b453cd5ab3cd8d9d35ea828c6fefb539b41c5e7f57b1dcba9a0a0f1cb2f90a80b4e03cc071fc904e2cf82212e6afb29062d50c2ebf36e798ce171f3ed48
DIST asio-1.30.2.tar.bz2 3196850 BLAKE2B d902fda2338d9717bb8f2f5d43468c5d0b64591814c3ae3134350650f0dd97bf241287347d324b11d0e6993b1b44373df13305d736df09ad3375ce4976f5bb27 SHA512 2d26cdcfcc0c310e82ab502551b51d70fd95ba4628bd306929e78539299974fc14aa6ba27cf256f1df7a56539cb885012ba02a202ae17bf817ee6311308a795a
EBUILD asio-1.30.2.ebuild 1230 BLAKE2B e5eb0ea0cfd08f955c58be83e780e8afac0627ea53acce55e15875172ddf63055e5c158845f13b9efd2f4fad7d09a39d82cc9d2a104dea2d3e839268e86903fc SHA512 b68d686f881d4a6d8aba6d7cfef391648102a9765da3d9ca9728be1f6e430b9d835f05b71d8375a794125e124ea6dacb0f725d60aa8e2d32a0114f68a827fb04
+EBUILD asio-1.34.0.ebuild 1040 BLAKE2B 461231c65158804da984772818d399887556f477aa6ea776a42bd47e8c94b21a70d7198ccefef592819f25826e7faa77063d1f1212c680a3e41789121e1d4962 SHA512 bd2c7e33772f4463f65c374fc0e5250f42209bd35f10fb3412716f04ab1749ed414dec7ef57b7529c2b0b32ed1ee3d3d01fd819255fef05e13fc383e8d9526c5
MISC metadata.xml 487 BLAKE2B 57785b73f498590d36241612367eda9036cc4ce85baa6c59e45a4c4f0b696f24f7bbe012eef33dd2e29a9c82fad82f75639e55f9c7a6e2e001b7ab48b65787cc SHA512 4a4f9713ea7274f730707dda0f2de0e0c19e50166466c0b8c3e5053e44fa5df02866235cfd97ebeaff15271cce662f1ae19383c0023813d429eded937d9b9cfb
diff --git a/dev-cpp/asio/asio-1.34.0.ebuild b/dev-cpp/asio/asio-1.34.0.ebuild
new file mode 100644
index 000000000000..c3ce1b16bbcb
--- /dev/null
+++ b/dev-cpp/asio/asio-1.34.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="https://github.com/chriskohlhoff/asio/archive/refs/tags/asio-${PV//./-}.tar.gz"
+S="${WORKDIR}/asio-asio-${PV//./-}/asio"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index fc96b7bcb54d..d22c14df2617 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,12 +1,7 @@
-AUX nlohmann_json-3.11.2-gcc13-2.patch 1830 BLAKE2B b0cbbee4195c58c42ec9d35387429ace8040cfb7ecf115cc73e16911e18c10ebf2a01a59744ead65295765340e540af84336392ac7831ee59fc75cfccf0230d3 SHA512 b3e0c373c5566be5e300a9a46a02c446132220903ec102637e4e6bdb821f524dceeb1db5501a96c16c61ca1a94a96dccd190287a8e31aceb85fb2151e5c8e5bb
-AUX nlohmann_json-3.11.2-gcc13.patch 3812 BLAKE2B 2c88e14333ddf47df921c0dd1bc250e478a08e3f59bfcc733dbd95f9209fe1cbd3f735f31844d2b80cef86da32694f993d348e45a0494c9e9d607ba62b83a46f SHA512 8a99f0b18efa8d2f5f6e5cca52e59b28012d5e10ea09f641b21abff3785058191ece7a6bd18d9cdc69d8ce1f12beb7d4f59301277636889b8250011ad2127087
DIST nlohmann_json-3.10.2.tar.gz 7054440 BLAKE2B e7da213fb75d528b1f5425822f5b598e882f232a67670aaae2d8f89c76e72ee23fa3344d1acfef2b0338a6a423d17b231b7e047ff064c984c2ec7783b721a22c SHA512 9a399dfc8aab19c9fc12470e8087895b1c05d48a9bcc731b483d8670c361cffb2adc3ccced822b7f17255e88387a441d619c4e1f1afeb702d1d035ad24fe22ed
-DIST nlohmann_json-3.11.2.tar.gz 8097673 BLAKE2B ebb67966739a330e0cfb8495a6eb58e87732655856a6d4e843072ed5e485cafbb8a75d8803859d0365b814deda7429448ecc473de414de4b23d3a3c455dc2511 SHA512 70097c9bcd7a91254acbd41b8b68a6aaa371fc2dd7011f472917f69f1e2d2986155a0339dad791699d542e4a3be44dc49ae72ff73d0ee0ea4b34183296ce19a0
DIST nlohmann_json-3.11.3.tar.gz 8053705 BLAKE2B 872f67e44d3003c9d8c9e5ca4674a357883d7341e3943a7694812af8c853fe5da65fbbe0cc986b634c7cbca12082a064fcf8e40d4d06e6b990f031ea47c21db5 SHA512 7df19b621de34f08d5d5c0a25e8225975980841ef2e48536abcf22526ed7fb99f88ad954a2cb823115db59ccc88d1dbe74fe6c281b5644b976b33fb78db9d717
DIST nlohmann_json-testdata-3.0.0.tar.gz 112348454 BLAKE2B f0a47b41805bf1426f612e9a82efea2a3e5b1c15740c1c531d859e60dc5daeb85209b4fe363fd8fb84e3bbf01a2578c74538ba3e769726494047979f5a4d468d SHA512 d9af8419b837c592ec7519cd5772651c761078a9c43cf2a309cee55c323aee0df0c233fb58a07d5ee2e77492ac8b16398de234b387eae037a60e3c9ba5b08891
DIST nlohmann_json-testdata-3.1.0.tar.gz 115036393 BLAKE2B 809be0728a0b9d007fcc752911bdf6f7e548d6e3ec59871ea2b16d87d8248ca4dd2f681a1d0f82c618463294188ad41d6d965b8bdc39c70fdcf4b939d4121e9c SHA512 db6c411b37f2154f5dd1ed90f4e8fa0907f4a736cd0ff79943bcacf9da422285ff142bb6a7dc6022b236090083166ac1ab197be3f480d8dc50b26a91a9477821
EBUILD nlohmann_json-3.10.2.ebuild 1577 BLAKE2B 2db087d7545ab034faf859f314b69ba645b3f5be0f589b96de763d9bc371aa148ce86c15332e08d516f854916e730cca8aa1f521ff0fd5aa5210500dc1d6dbf9 SHA512 fda0401e5bbdf6b49f2f1a8694780ab43da076612fc4224e5ca012bf014c132bb1c7923939226793272fa7546c00a79f8eb40ef1905b5cdf714fe08f26833539
-EBUILD nlohmann_json-3.11.2-r1.ebuild 2069 BLAKE2B d8a1d7efff14b2332f18d3dc1af37f09213d5a872a1ed3a789c701464aa8d8b4d93f8848b24618e1321476c58384d3801af083371400a459661bf47a0601b95f SHA512 a131d2f949c94122809acbc5c8c47629a7f815026b7f7dd14aad071d07a768f50c4d50c6a29cbff3bb34e813bf3b6f99e9ecae1d5c91c5994b9a2ad5be0929cf
-EBUILD nlohmann_json-3.11.2.ebuild 1968 BLAKE2B 0189ac08dad78df6b312780263ef313d6e50cf2687a8b54b68f42289e20bed3e7d7be4778568dd43676fd8baa608b179582656448e71a01826e2ea661cc16752 SHA512 0e6d817be5007b7d82b419cbc1b2a30188e9384d230d1ceb73ca067c63db8ec3f04630cde569466ed3509002c07c9849a14d2e940e58d6b2d59d31de0d1a409d
EBUILD nlohmann_json-3.11.3.ebuild 1975 BLAKE2B 3961a6363ee607510dd03a8888a98af856c1c975a3dcd72713f19daf731159b2d06493e84027fc9df9f2b7e76a6ced09d4789e1fcbb2fa639a973066cb91ed66 SHA512 359c8471fa66c9473f67d2f067834958519764d0cdac037d919ca7a828c217b7122f9f7b395be78efabdc715001492dfdcb945716caf0caf16eafedce87a804e
MISC metadata.xml 338 BLAKE2B c5eb95ba7048308eab4753ea01c015781ce85db42d2e50f8ed9e3f7fb6945cfb8b90f5b3216799ad53137ceef6eae4636eea482e86206b19589ddf2e42caaaa1 SHA512 4198102ff79678a8e9be9146fc97991b1b205be3d34ebaece3dcab46a36ee5af904f463fcd0dc2a88fb362aa7a81e8d713af7b55db594a7069efc0276c94ff49
diff --git a/dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13-2.patch b/dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13-2.patch
deleted file mode 100644
index a2931880dbcd..000000000000
--- a/dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13-2.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From a49829bd984c0282be18fcec070df0c31bf77dd5 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@gentoo.org>
-Date: Tue, 21 Feb 2023 12:59:21 +0100
-Subject: [PATCH] tests/unit-iterators2: use std::ranges::equals for range
- comparisons
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This fixes a build error on GCC 13:
-
- /home/arsen/nlohmann_json/tests/src/unit-iterators2.cpp: In function ‘void _DOCTEST_ANON_FUNC_2()’:
- /home/arsen/nlohmann_json/tests/src/unit-iterators2.cpp:946:32: error: no match for ‘operator==’ (operand types are ‘doctest::detail::Expression_lhs<std::ranges::reverse_view<std::ranges::ref_view<nlohmann::json_abi_v3_11_2::basic_json<> > >&>’ and ‘nlohmann::json_abi_v3_11_2::json’ {aka ‘nlohmann::json_abi_v3_11_2::basic_json<>’})
- 946 | CHECK(reversed == j_expected);
- | ^~ ~~~~~~~~~~
- | |
- | nlohmann::json_abi_v3_11_2::json {aka nlohmann::json_abi_v3_11_2::basic_json<>}
-
-Bug: https://bugs.gentoo.org/895692
-Closes: #3927
----
-Forwarded: https://github.com/nlohmann/json/pull/3950
-
- tests/src/unit-iterators2.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/src/unit-iterators2.cpp b/tests/src/unit-iterators2.cpp
-index 27926084..72a5d9dc 100644
---- a/tests/src/unit-iterators2.cpp
-+++ b/tests/src/unit-iterators2.cpp
-@@ -943,7 +943,7 @@ TEST_CASE("iterators 2")
- json j_expected{5, 4, 3, 2, 1};
-
- auto reversed = j | std::views::reverse;
-- CHECK(reversed == j_expected);
-+ CHECK(std::ranges::equal(reversed, j_expected));
- }
-
- SECTION("transform")
---
-2.39.2
-
diff --git a/dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13.patch b/dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13.patch
deleted file mode 100644
index 5205e67a3c2c..000000000000
--- a/dev-cpp/nlohmann_json/files/nlohmann_json-3.11.2-gcc13.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-https://github.com/nlohmann/json/issues/3927
-https://github.com/nlohmann/json/pull/3895
-
-From a5b09d50b786638ed9deb09ef13860a3cb64eb6b Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyich@gmail.com>
-Date: Tue, 20 Dec 2022 22:08:12 +0000
-Subject: [PATCH] custom allocators: define missing 'rebind' type
-
-`gcc-13` added an assert to standard headers to make sure custom
-allocators have intended implementation of rebind type instead
-of inherited rebind. gcc change:
- https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=64c986b49558a7
-
-Without the fix build fails on this week's `gcc-13` as:
-
- In file included from <<NIX>>-gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:34,
- from <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/basic_string.h:39,
- from <<NIX>>-gcc-13.0.0/include/c++/13.0.0/string:54,
- from <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/locale_classes.h:40,
- from <<NIX>>-gcc-13.0.0/include/c++/13.0.0/locale:41,
- from tests/src/unit-regression2.cpp:19:
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h: In instantiation of 'struct std::__allocator_traits_base::__rebind<my_allocator<unsigned char>, unsigned char, void>':
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:94:11: required by substitution of 'template<class _Alloc, class _Up> using std::__alloc_rebind = typename std::__allocator_traits_base::__rebind<_Alloc, _Up>::type [with _Alloc = my_allocator<unsigned char>; _Up = unsigned char]'
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:228:8: required by substitution of 'template<class _Alloc> template<class _Tp> using std::allocator_traits< <template-parameter-1-1> >::rebind_alloc = std::__alloc_rebind<_Alloc, _Tp> [with _Tp = unsigned char; _Alloc = my_allocator<unsigned char>]'
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:126:65: required from 'struct __gnu_cxx::__alloc_traits<my_allocator<unsigned char>, unsigned char>::rebind<unsigned char>'
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:88:21: required from 'struct std::_Vector_base<unsigned char, my_allocator<unsigned char> >'
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:423:11: required from 'class std::vector<unsigned char, my_allocator<unsigned char> >'
- tests/src/unit-regression2.cpp:807:63: required from here
- <<NIX>>-gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:70:31: error: static assertion failed: allocator_traits<A>::rebind_alloc<A::value_type> must be A
- 70 | _Tp>::value,
- | ^~~~~
-
-The change adds trivial `rebind` definition with expected return type
-and satisfies conversion requirements.
---- a/tests/src/unit-allocator.cpp
-+++ b/tests/src/unit-allocator.cpp
-@@ -20,11 +20,20 @@ struct bad_allocator : std::allocator<T>
- {
- using std::allocator<T>::allocator;
-
-+ bad_allocator() = default;
-+ template<class U> bad_allocator(const bad_allocator<U>& /*unused*/) { }
-+
- template<class... Args>
- void construct(T* /*unused*/, Args&& ... /*unused*/)
- {
- throw std::bad_alloc();
- }
-+
-+ template <class U>
-+ struct rebind
-+ {
-+ using other = bad_allocator<U>;
-+ };
- };
- } // namespace
-
---- a/tests/src/unit-regression2.cpp
-+++ b/tests/src/unit-regression2.cpp
-@@ -187,6 +187,15 @@ class my_allocator : public std::allocator<T>
- {
- public:
- using std::allocator<T>::allocator;
-+
-+ my_allocator() = default;
-+ template<class U> my_allocator(const my_allocator<U>& /*unused*/) { }
-+
-+ template <class U>
-+ struct rebind
-+ {
-+ using other = my_allocator<U>;
-+ };
- };
-
- /////////////////////////////////////////////////////////////////////
-
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2-r1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.11.2-r1.ebuild
deleted file mode 100644
index c99929f0867e..000000000000
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-#DOCS_BUILDER="mkdocs"
-# Needs unpackaged plantuml-markdown too
-# ... but plantuml (Python bindings anyway) need network access to generate bits at runtime.
-#DOCS_DEPEND="dev-python/mkdocs-material-extensions dev-python/mkdocs-minify-plugin"
-#DOCS_DIR="doc/mkdocs"
-inherit cmake
-
-# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
-TEST_VERSION="3.1.0"
-DESCRIPTION="JSON for Modern C++"
-HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="
- https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
-S="${WORKDIR}/json-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DOCS=( ChangeLog.md README.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.11.2-gcc13.patch
- "${FILESDIR}"/${PN}-3.11.2-gcc13-2.patch
-)
-
-src_prepare() {
- if use test ; then
- ln -s "${WORKDIR}"/json_test_data-${TEST_VERSION} "${S}"/json_test_data || die
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Tests are built by default so we can't group the test logic below
- local mycmakeargs=(
- -DJSON_MultipleHeaders=ON
- -DJSON_BuildTests=$(usex test)
- )
-
- # Define test data directory here to avoid unused var QA warning, bug #747826
- use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}"/tests || die
-
- # git_required:
- # Skip certain tests needing git per upstream
- # https://github.com/nlohmann/json/issues/2189
- #
- # cmake_fetch_content_configure, cmake_fetch_content2_configure:
- # Needs network (bug #865027, bug #865105)
- local myctestargs=(
- -E "(git_required|cmake_fetch_content_configure|cmake_fetch_content2_configure|cmake_fetch_content_build|cmake_fetch_content2_build)"
- )
-
- cmake_src_test
-}
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
deleted file mode 100644
index 86bb5e2e2106..000000000000
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-#DOCS_BUILDER="mkdocs"
-# Needs unpackaged plantuml-markdown too
-# ... but plantuml (Python bindings anyway) need network access to generate bits at runtime.
-#DOCS_DEPEND="dev-python/mkdocs-material-extensions dev-python/mkdocs-minify-plugin"
-#DOCS_DIR="doc/mkdocs"
-inherit cmake
-
-# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
-TEST_VERSION="3.1.0"
-DESCRIPTION="JSON for Modern C++"
-HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="
- https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
-S="${WORKDIR}/json-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ppc64 ~riscv x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DOCS=( ChangeLog.md README.md )
-
-src_prepare() {
- if use test ; then
- ln -s "${WORKDIR}"/json_test_data-${TEST_VERSION} "${S}"/json_test_data || die
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- # Tests are built by default so we can't group the test logic below
- local mycmakeargs=(
- -DJSON_MultipleHeaders=ON
- -DJSON_BuildTests=$(usex test)
- )
-
- # Define test data directory here to avoid unused var QA warning, bug #747826
- use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}"/tests || die
-
- # git_required:
- # Skip certain tests needing git per upstream
- # https://github.com/nlohmann/json/issues/2189
- #
- # cmake_fetch_content_configure, cmake_fetch_content2_configure:
- # Needs network (bug #865027, bug #865105)
- local myctestargs=(
- -E "(git_required|cmake_fetch_content_configure|cmake_fetch_content2_configure|cmake_fetch_content_build|cmake_fetch_content2_build)"
- )
-
- cmake_src_test
-}
diff --git a/dev-cpp/sol2/Manifest b/dev-cpp/sol2/Manifest
index d0e05b5aee94..249c47f9d650 100644
--- a/dev-cpp/sol2/Manifest
+++ b/dev-cpp/sol2/Manifest
@@ -4,6 +4,10 @@ AUX sol2-3.3.0-cmake-dir.patch 1065 BLAKE2B 906ea8df35dfb8908bf114ac9fc6fbcfae9d
AUX sol2-3.3.0-dont-install-tests.patch 289 BLAKE2B fc82c80a6b5fcc651b43308d1604414249ee462c406554b9b61aece253983c76cce1ee691d404e6486bbd566e521953ce076206053e2bf4bee9ee7f2944434d2 SHA512 bd43744581315bab42b603a3b1e163a86f36936bc444eb1c67504a710323978b53d00bb5b9fb8865e4d5831c80f713a52cc4bd4e02c2dd054840dd47153461c6
AUX sol2-3.3.0-werror.patch 854 BLAKE2B 4ba8febe3e225a904501a61d0bf7bb5a8539b1c8dca65e67ce5b335116851549ab31321126eecc3b8b9c9439491fd8c097430b15fce17c42a8ddc73f50a4fd0d SHA512 00b267ab451cfa9210db5a3ce5de67b33c58438a46be8178cce4dcf1ffd31ca2e5bde0015ccb72e2e641b7a0a59996d88154acc765b6eb3891bb092bec0bf46b
AUX sol2-3.3.1-fix-emplace.patch 660 BLAKE2B b36439910c10c2bb3c86d5911c3aaf20906e411d7fddc40ad2c201c685cf8feea4c49e4e5835396c4d6d1447ea672b55e2f55e7291e74d0eb7f4add9bab7e91f SHA512 3563d2d272bb5d281c4d9875b5ec0cc94548adc0b3ca58f648a20e26e0d180fbb0b35e21d3b6a0ca51808b4744aff4796ef599c6cd17bcc44697e20ff951fb61
+AUX sol2-3.5.0-catch-depend.patch 376 BLAKE2B fe854499bbeef99f57925365de8b2ac526400c9d625f6938554cdd484733a81ae0ef4e334cfae34e28841301cf679ee1fce2c43568313607e6fafe029d5f0e3e SHA512 86f1ec9c136ff89b2f6b3e8c9ed8817c6fc531d135778bf1d955d28da441b090e4642775624dacda07a0c3840219acd13e007707d76b6ee3a9d68898664bebe2
+AUX sol2-3.5.0-luajit-pkgconf.patch 660 BLAKE2B 6423abb35408004a755fe8bed9b8b631ed645d79bc41e93c36f81d7c792307dbcbe8274f646eecb12470a019a4882c0883df98c42a99cdf157d35ead324a0525 SHA512 c97b0c0fab8be6cf48f872ec6587dee927e062f54a3199e9ad043f08a02e65d8ff89845e76f41f84571887e4c5bdd4c602ce3c35fa7a7281696eca6cf70f0a90
DIST sol2-3.3.1.tar.gz 8453954 BLAKE2B f9fced4f001a5f681598e45bf74cdf064f655c950be5b91789d2bf66c0180b5048610d3d4416c024a07db11d41fceaee786800c5ca1412811cbc1a449a894a9e SHA512 4404b124a4f331d77459c01a92cd73895301e7d3ef829a0285980f0138b9cc66782de3713d54f017d5aad7d8a11d23eeffbc5f3b39ccb4d4306a955711d385dd
+DIST sol2-3.5.0.tar.gz 8461779 BLAKE2B a86fe9313457d097bc078407d5e00e08ba9f6f9b898779a0c50891b3313db5a4a3fb22c660f79e8d419a4f020ff8d914e10144f2fbb2ede27b695ad697f4c8ff SHA512 5a6ec7e16dae05ad6abea02842f62db8f64935eda438d67b2c264cbee80cee6d82200bd060387c6df837fe9f212dbe22b2772af34df1ce8bd43296dd9429558d
EBUILD sol2-3.3.1-r1.ebuild 1404 BLAKE2B f4b7ca3ba02f29728b5ecf0ddcaec5722d07a185ce780812456b3ba0a9a69ed92062622ddf9245ff2b8f834a9f5a2597f89fd6d24bcdc342ecd3ee9b5d77c39f SHA512 69792db4cce41f83202a82dfe1b938ae6fcc5d82a2c42a6dcab9488396c03b3f7aa46f0b641541ed0eeefcda069922b146575165d411f53e2a1366058d6ddb6f
+EBUILD sol2-3.5.0.ebuild 1318 BLAKE2B cfa305eb2a366ff342ad66c94c37b1ddc59178ce7a16899286c9036e6be030f8e7cc34d8e630db394c134edf6016e08a1eab34e6bb335e304129dc02d79cbec0 SHA512 91a2818dbe543849eb43c2d738e6ee29ca262db147276a15ca2c491f06336cafcca87f0033f462a16aa84e9919e2dfa66103b34deea01d4a8bcb460e9f331dd0
MISC metadata.xml 594 BLAKE2B 911a1123a653118d9c19c3ff1a42a979a696d034500eda29a18c72e6f89bcc2f7c4d28977c76a40f61b79649c3f4aa63439cda96311e2cdd2bc9495ad1a85db1 SHA512 5c8252373ee8bdefe9b2863df048616beec0d00dcf1cd7845302721f78158db48729d9ab412dbcf4bed49130518acd2071ca3e5880488a882117ec5728e26b9a
diff --git a/dev-cpp/sol2/files/sol2-3.5.0-catch-depend.patch b/dev-cpp/sol2/files/sol2-3.5.0-catch-depend.patch
new file mode 100644
index 000000000000..1b5c4f1de1af
--- /dev/null
+++ b/dev-cpp/sol2/files/sol2-3.5.0-catch-depend.patch
@@ -0,0 +1,16 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -23,12 +23,7 @@
+ # # # # sol2 tests
+
+ # # Dependencies
+-FetchContent_Declare(
+- Catch2
+- GIT_REPOSITORY https://github.com/catchorg/Catch2.git
+- GIT_TAG devel
+-)
+-FetchContent_MakeAvailable(Catch2)
++find_package(Catch2 REQUIRED)
+
+ function(sol2_add_test_properties target-name)
+ target_link_libraries(${target-name}
diff --git a/dev-cpp/sol2/files/sol2-3.5.0-luajit-pkgconf.patch b/dev-cpp/sol2/files/sol2-3.5.0-luajit-pkgconf.patch
new file mode 100644
index 000000000000..2422d29a90fc
--- /dev/null
+++ b/dev-cpp/sol2/files/sol2-3.5.0-luajit-pkgconf.patch
@@ -0,0 +1,17 @@
+Use the lua version selected by lua eclass
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -188,7 +188,11 @@ if (SOL2_IS_TOP_LEVEL AND (SOL2_DO_TESTS OR SOL2_DO_EXAMPLES))
+
+ string(TOLOWER ${SOL2_LUA_VERSION} NORMALIZED_LUA_VERSION)
+ # Find way to get Lua: build if requested, or attempt to build if no matching version is found
+- if (SOL2_BUILD_LUA)
++ if (TRUE)
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(LUA REQUIRED lua IMPORTED_TARGET)
++ add_library(Lua::Lua ALIAS PkgConfig::LUA)
++ elseif (SOL2_BUILD_LUA)
+ find_package(LuaBuild REQUIRED COMPONENTS ${SOL2_LUA_VERSION})
+ elseif (NOT SOL2_LUA_VERSION)
+ find_package(LuaBuild REQUIRED)
diff --git a/dev-cpp/sol2/sol2-3.5.0.ebuild b/dev-cpp/sol2/sol2-3.5.0.ebuild
new file mode 100644
index 000000000000..3d483db70d0e
--- /dev/null
+++ b/dev-cpp/sol2/sol2-3.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1,3,4} luajit )
+inherit cmake lua
+
+DESCRIPTION="Header-only C++ <-> Lua API wrapper"
+HOMEPAGE="https://github.com/ThePhD/sol2"
+SRC_URI="https://github.com/ThePhD/sol2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ ${LUA_DEPS}
+ test? (
+ >=dev-cpp/catch-3
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/sol2-3.3.0-werror.patch
+ "${FILESDIR}"/sol2-3.5.0-luajit-pkgconf.patch
+ "${FILESDIR}"/sol2-3.5.0-catch-depend.patch
+ "${FILESDIR}"/sol2-3.3.0-dont-install-tests.patch
+)
+
+src_configure() {
+ sol2_configure_wrapper() {
+ local mycmakeargs=(
+ -DSOL2_BUILD_LUA=no
+ -DSOL2_TESTS=$(usex test)
+ -DSOL2_LUA_VERSION="${ELUA}"
+ )
+ cmake_src_configure
+ }
+ lua_foreach_impl sol2_configure_wrapper
+}
+
+src_compile() {
+ lua_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ sol2_test_wrapper() {
+ if [[ ${ELUA} == luajit ]]; then
+ einfo "Skipping test due to https://github.com/ThePhD/sol2/issues/1221"
+ else
+ cmake_src_test
+ fi
+ }
+ lua_foreach_impl sol2_test_wrapper
+}
+
+src_install() {
+ lua_foreach_impl cmake_src_install
+}