summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin11238 -> 10909 bytes
-rw-r--r--dev-cpp/libcutl/Manifest5
-rw-r--r--dev-cpp/libcutl/files/libcutl-1.10.0-boost-1.65-tr1.patch162
-rw-r--r--dev-cpp/libcutl/files/libcutl-1.10.0-fix-c++14.patch53
-rw-r--r--dev-cpp/libcutl/libcutl-1.10.0.ebuild52
-rw-r--r--dev-cpp/libcutl/metadata.xml5
-rw-r--r--dev-cpp/libxsd-frontend/Manifest3
-rw-r--r--dev-cpp/libxsd-frontend/libxsd-frontend-2.0.0-r1.ebuild87
-rw-r--r--dev-cpp/libxsd-frontend/metadata.xml5
9 files changed, 0 insertions, 372 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 378d4e3e3613..db9de2cfd46e 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/libcutl/Manifest b/dev-cpp/libcutl/Manifest
deleted file mode 100644
index ca785bfcac65..000000000000
--- a/dev-cpp/libcutl/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX libcutl-1.10.0-boost-1.65-tr1.patch 4688 BLAKE2B b896957b8a1ff399b51210052df2eb080ef52d887ad6e4734921945c497e172c8f9557c371947f4ba759d50911db4d9b99cd6a62a3765eabb29b0743fa407945 SHA512 0fc264a7e8b19c1da93384ec799cf2f8178af26f2baca53d92530ca6086371a6fc6ba5b7c8134b318846079b99fb2ba8872e1b14ab58da4422e0309bcbfe2b9f
-AUX libcutl-1.10.0-fix-c++14.patch 1045 BLAKE2B 91e954048739a53dc5dcf757ee7b3541b958fc30063df2da3ffe47f9c020ee8f80cfde07d351b21ac8ebabb00a84ed5f29b6063082fe18374172129537e0a6a0 SHA512 37033c583b55e66d4edc03e483f01e3c6d331862748eaa23cecc8a24614368d294193642c481ba91d9ee56eed952c6ad0f4997e30ace9e572653b3780be75cec
-DIST libcutl-1.10.0.tar.bz2 763920 BLAKE2B 8d6741b19cc7c1d320225b6f412c08d6dd1d975a9f1e2f55914a23b8813e42228616ea525905bcf456f4b6e60a72fbf4128a03275833975ce3b8c87d6e4cb631 SHA512 c03f39e87e660fdd07aa9cccb2d82d411ca8226b56475c74b7b2147b90cdb83d13246bc0c09513e407271bcf568d6a08f92c9006e48d1e7f06e4b18dde34dc5f
-EBUILD libcutl-1.10.0.ebuild 1027 BLAKE2B b9c108c5076b18a9b6e10cdd90a6180a0948ec0b39b2190d09a7c2979ecdecb5f12b9c4283d8e5fe78ec665495d6cef6eaa06f765364f9d9f198cd4f05e11bdc SHA512 c05e606af9647aa004d87986bdb2db55f5d58ba26103066df11f9c50f3cf909de7b28298023c61c5fd79c9c8f3430860a91b8203d0decd725c6f69d2c1f42dfd
-MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/dev-cpp/libcutl/files/libcutl-1.10.0-boost-1.65-tr1.patch b/dev-cpp/libcutl/files/libcutl-1.10.0-boost-1.65-tr1.patch
deleted file mode 100644
index ebb15ee9b404..000000000000
--- a/dev-cpp/libcutl/files/libcutl-1.10.0-boost-1.65-tr1.patch
+++ /dev/null
@@ -1,162 +0,0 @@
-Use regex from C++11 instead of boost/tr1's version (the latter is gone as of boost 1.65).
-Patch: https://svnweb.freebsd.org/ports/head/devel/libcutl/files/patch-cutl_re_re.cxx?view=markup&pathrev=445764
-Bug: https://bugs.gentoo.org/show_bug.cgi?id=630016
-
---- a/cutl/re/re.cxx
-+++ b/cutl/re/re.cxx
-@@ -9,7 +9,7 @@
- #ifndef LIBCUTL_EXTERNAL_BOOST
- # include <cutl/details/boost/tr1/regex.hpp>
- #else
--# include <boost/tr1/regex.hpp>
-+# include <regex>
- #endif
-
- using namespace std;
-@@ -40,17 +40,17 @@
- struct basic_regex<C>::impl
- {
- typedef basic_string<C> string_type;
-- typedef tr1::basic_regex<C> regex_type;
-+ typedef std::basic_regex<C> regex_type;
- typedef typename regex_type::flag_type flag_type;
-
- impl () {}
- impl (regex_type const& r): r (r) {}
- impl (string_type const& s, bool icase)
- {
-- flag_type f (tr1::regex_constants::ECMAScript);
-+ flag_type f (std::regex_constants::ECMAScript);
-
- if (icase)
-- f |= tr1::regex_constants::icase;
-+ f |= std::regex_constants::icase;
-
- r.assign (s, f);
- }
-@@ -118,15 +118,15 @@
- impl_ = s == 0 ? new impl : new impl (*s, icase);
- else
- {
-- impl::flag_type f (tr1::regex_constants::ECMAScript);
-+ impl::flag_type f (std::regex_constants::ECMAScript);
-
- if (icase)
-- f |= tr1::regex_constants::icase;
-+ f |= std::regex_constants::icase;
-
- impl_->r.assign (*s, f);
- }
- }
-- catch (tr1::regex_error const& e)
-+ catch (std::regex_error const& e)
- {
- throw basic_format<char> (s == 0 ? "" : *s, e.what ());
- }
-@@ -146,15 +146,15 @@
- impl_ = s == 0 ? new impl : new impl (*s, icase);
- else
- {
-- impl::flag_type f (tr1::regex_constants::ECMAScript);
-+ impl::flag_type f (std::regex_constants::ECMAScript);
-
- if (icase)
-- f |= tr1::regex_constants::icase;
-+ f |= std::regex_constants::icase;
-
- impl_->r.assign (*s, f);
- }
- }
-- catch (tr1::regex_error const& e)
-+ catch (std::regex_error const& e)
- {
- throw basic_format<wchar_t> (s == 0 ? L"" : *s, e.what ());
- }
-@@ -166,28 +166,28 @@
- bool basic_regex<char>::
- match (string_type const& s) const
- {
-- return tr1::regex_match (s, impl_->r);
-+ return std::regex_match (s, impl_->r);
- }
-
- template <>
- bool basic_regex<wchar_t>::
- match (string_type const& s) const
- {
-- return tr1::regex_match (s, impl_->r);
-+ return std::regex_match (s, impl_->r);
- }
-
- template <>
- bool basic_regex<char>::
- search (string_type const& s) const
- {
-- return tr1::regex_search (s, impl_->r);
-+ return std::regex_search (s, impl_->r);
- }
-
- template <>
- bool basic_regex<wchar_t>::
- search (string_type const& s) const
- {
-- return tr1::regex_search (s, impl_->r);
-+ return std::regex_search (s, impl_->r);
- }
-
- template <>
-@@ -196,13 +196,13 @@
- string_type const& sub,
- bool first_only) const
- {
-- tr1::regex_constants::match_flag_type f (
-- tr1::regex_constants::format_default);
-+ std::regex_constants::match_flag_type f (
-+ std::regex_constants::format_default);
-
- if (first_only)
-- f |= tr1::regex_constants::format_first_only;
-+ f |= std::regex_constants::format_first_only;
-
-- return tr1::regex_replace (s, impl_->r, sub, f);
-+ return std::regex_replace (s, impl_->r, sub, f);
- }
-
- template <>
-@@ -211,13 +211,13 @@
- string_type const& sub,
- bool first_only) const
- {
-- tr1::regex_constants::match_flag_type f (
-- tr1::regex_constants::format_default);
-+ std::regex_constants::match_flag_type f (
-+ std::regex_constants::format_default);
-
- if (first_only)
-- f |= tr1::regex_constants::format_first_only;
-+ f |= std::regex_constants::format_first_only;
-
-- return tr1::regex_replace (s, impl_->r, sub, f);
-+ return std::regex_replace (s, impl_->r, sub, f);
- }
- }
- }
---- a/m4/libboost.m4
-+++ b/m4/libboost.m4
-@@ -129,13 +129,13 @@
- AC_DEFUN([LIBBOOST_REGEX], [
- LIBBOOST_LIB([regex],[
- AC_LANG_SOURCE([
--#include <boost/tr1/regex.hpp>
-+#include <regex>
-
- int
- main ()
- {
-- std::tr1::regex r ("te.t", std::tr1::regex_constants::ECMAScript);
-- return std::tr1::regex_match ("test", r) ? 0 : 1;
-+ std::regex r ("te.t", std::regex_constants::ECMAScript);
-+ return std::regex_match ("test", r) ? 0 : 1;
- }
- ])],
- [$1],
diff --git a/dev-cpp/libcutl/files/libcutl-1.10.0-fix-c++14.patch b/dev-cpp/libcutl/files/libcutl-1.10.0-fix-c++14.patch
deleted file mode 100644
index a6f1a505485b..000000000000
--- a/dev-cpp/libcutl/files/libcutl-1.10.0-fix-c++14.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Make dtors noexcept(false) when compiling in C++11 and above. This avoids silent
-breakage due to the semantic exception changes between C++98 and C++11.
-
---- a/cutl/fs/auto-remove.cxx
-+++ b/cutl/fs/auto-remove.cxx
-@@ -13,6 +13,9 @@
- {
- auto_remove::
- ~auto_remove ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- if (!canceled_)
- {
-@@ -23,6 +26,9 @@
-
- auto_removes::
- ~auto_removes ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- if (!canceled_)
- {
---- a/cutl/fs/auto-remove.hxx
-+++ b/cutl/fs/auto-remove.hxx
-@@ -26,7 +26,11 @@
- {
- }
-
-- ~auto_remove ();
-+ ~auto_remove ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- void
- cancel ()
-@@ -51,7 +55,11 @@
- struct LIBCUTL_EXPORT auto_removes
- {
- auto_removes (): canceled_ (false) {}
-- ~auto_removes ();
-+ ~auto_removes ()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
- void
- add (path const& p)
diff --git a/dev-cpp/libcutl/libcutl-1.10.0.ebuild b/dev-cpp/libcutl/libcutl-1.10.0.ebuild
deleted file mode 100644
index b88f5363b9ee..000000000000
--- a/dev-cpp/libcutl/libcutl-1.10.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic versionator
-
-DESCRIPTION="A collection of C++ libraries (successor of libcult)"
-HOMEPAGE="https://www.codesynthesis.com/projects/libcutl/"
-SRC_URI="https://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/expat
- dev-libs/boost:="
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.10.0-fix-c++14.patch
- "${FILESDIR}"/${PN}-1.10.0-boost-1.65-tr1.patch
-)
-
-src_prepare() {
- default
-
- # remove bundled libs
- rm -r cutl/details/{boost,expat} || die
-
- eautoreconf
-}
-
-src_configure() {
- # ensure <regex> works on GCC 5 and below
- # bug 630016
- append-cxxflags -std=c++14
-
- econf \
- --disable-static \
- --with-external-boost \
- --with-external-expat
-}
-
-src_install() {
- default
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/dev-cpp/libcutl/metadata.xml b/dev-cpp/libcutl/metadata.xml
deleted file mode 100644
index 7a38bb900964..000000000000
--- a/dev-cpp/libcutl/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-cpp/libxsd-frontend/Manifest b/dev-cpp/libxsd-frontend/Manifest
deleted file mode 100644
index 6e5081a07c5a..000000000000
--- a/dev-cpp/libxsd-frontend/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST libxsd-frontend-2.0.0.tar.bz2 66784 BLAKE2B 3d41a97dc01f7d9231f981043ab00523f27decba428395940dd008b9a35e434e9f1a002f4214c11fe4fb9d228149eb3e05ba7da3d7682ae9d334d3d0db66dc1d SHA512 8a296fdfe2e562237d46774b33ee82e8f67835b0869c03ffdf04570db1e6f398cf97734685d44c2207abbb73cea20b57e53c8fd80a121f98196c1c7d4bacbc68
-EBUILD libxsd-frontend-2.0.0-r1.ebuild 2142 BLAKE2B ad44e514875e693d803c8b04786ae629bf56a38ee3a77ba05740e386017a6ef250d2aceafe8c9b06073ea636a8f3e33b0de7cb97243ea4d2a1dec28a949bb9e4 SHA512 678d5541971c93c1b20bcd36340328e77b289c674fc27d486b6a13b3ddc1afcb02823986a0aef7535a096e92ed1d766794ed296b92ce92ea9f118345b4e383f4
-MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/dev-cpp/libxsd-frontend/libxsd-frontend-2.0.0-r1.ebuild b/dev-cpp/libxsd-frontend/libxsd-frontend-2.0.0-r1.ebuild
deleted file mode 100644
index 9a16fd1f89a8..000000000000
--- a/dev-cpp/libxsd-frontend/libxsd-frontend-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs versionator
-
-DESCRIPTION="A compiler frontend for the W3C XML Schema definition language"
-HOMEPAGE="https://www.codesynthesis.com/projects/libxsd-frontend/"
-SRC_URI="https://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=dev-libs/xerces-c-3.0.0
- dev-libs/boost:=[threads(+)]
- dev-cpp/libcutl"
-DEPEND="${RDEPEND}
- >=dev-util/build-0.3.10"
-
-src_configure() {
- mkdir -p \
- build/{ld,cxx/gnu} \
- build/import/lib{boost,cult,frontend-elements,xerces-c} || die
-
- cat >> build/cxx/configuration-dynamic.make <<- EOF || die
- cxx_id := gnu
- cxx_optimize := n
- cxx_debug := n
- cxx_rpath := n
- cxx_pp_extra_options :=
- cxx_extra_options := ${CXXFLAGS}
- cxx_ld_extra_options := ${LDFLAGS}
- cxx_extra_libs :=
- cxx_extra_lib_paths :=
- EOF
-
- cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF || die
- cxx_gnu := $(tc-getCXX)
- cxx_gnu_libraries :=
- cxx_gnu_optimization_options :=
- EOF
-
- cat >> build/ld/configuration-lib-dynamic.make <<- EOF || die
- ld_lib_type := shared
- EOF
-
- # boost
- cat >> build/import/libboost/configuration-dynamic.make <<- EOF || die
- libboost_installed := y
- libboost_system := y
- EOF
-
- # libcutl
- cat >> build/import/libcutl/configuration-dynamic.make <<- EOF || die
- libcutl_installed := y
- EOF
-
- # xerces-c
- cat >> build/import/libxerces-c/configuration-dynamic.make <<- EOF || die
- libxerces_c_installed := y
- EOF
-}
-
-src_compile() {
- emake verbose=1
-}
-
-src_install() {
- einstalldocs
-
- dolib.so xsd-frontend/libxsd-frontend.so
-
- # clean header dir of build files
- find xsd-frontend \( -iname '*.cxx' -o -iname 'makefile*' \
- -o -iname '*.o' -o -iname '*.d' -o -iname '*.m4' -o -iname '*.l' \
- -o -iname '*.cpp-options' -o -iname '*.so' \) -exec rm -rf '{}' + || die
- rm -rf xsd-frontend/arch || die
- doheader -r xsd-frontend
-}
-
-src_test() {
- export LD_LIBRARY_PATH="${S}/xsd-frontend:${LD_LIBRARY_PATH}"
- default
-}
diff --git a/dev-cpp/libxsd-frontend/metadata.xml b/dev-cpp/libxsd-frontend/metadata.xml
deleted file mode 100644
index 7a38bb900964..000000000000
--- a/dev-cpp/libxsd-frontend/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
-</pkgmetadata>