summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin16850 -> 16852 bytes
-rw-r--r--dev-cpp/elfio/Manifest3
-rw-r--r--dev-cpp/elfio/elfio-3.12.ebuild4
-rw-r--r--dev-cpp/elfio/files/elfio-3.12-gcc15.patch24
4 files changed, 28 insertions, 3 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 34c6de416d64..b757937f2c16 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/elfio/Manifest b/dev-cpp/elfio/Manifest
index c2bfc9ae9df4..db081bc321d6 100644
--- a/dev-cpp/elfio/Manifest
+++ b/dev-cpp/elfio/Manifest
@@ -1,4 +1,5 @@
+AUX elfio-3.12-gcc15.patch 588 BLAKE2B 54698393ee02d28015cb45a3f93f42ea3b4fc2fbcc4d80d3698c0ecebbc25cd3236af1e1c4ef18b8c6f6c99ad2b8799d40df0e686eff16fdfb4856ef805137c1 SHA512 3bcaadb046fe11a854c496610835a61c3acb3844e1233f7a1c87d3036bd49c84b8c3f0c8fcdac7f148bf3ec65e1832af159b8a493e24f2a23bf5ae32507100f1
AUX elfio-3.12-gnuinstalldirs-docdir.patch 469 BLAKE2B a265a5c2ee8c604ff606276e224487c5a5bb3ac694d185755f6a7bd5444352a2b04918e8d308836b6ec339062db9c24c74e00cf80ad7bf9852410dc6b01360bf SHA512 a08328d732b811618fb701c6b27406e0a2495efca6f0fbfd9bbaf9e69152edbdc17e7dfb55096590c96c60bba0acf2d73d11b7e953aedca7189f074cd248f221
DIST elfio-3.12.tar.gz 4150640 BLAKE2B aba7c4a9c254384b3babcf740883e45b8b531ecde3bc12f3cb811ac63c1469d0d53d9bb259120d92bacad7289d811429785a784667d4632c3acc49f2c3a475e4 SHA512 f5c8bc6cc98da845f6c011fc85b98476935c5d20d72b36bff5ad2472434494115ee7c06cfa37152c528e5931c39fe3cc084bfc8e6952b2c3e8f24b8601ae212f
-EBUILD elfio-3.12.ebuild 765 BLAKE2B ba3f197f5f66344b6b293170f3094ec44815661049e5e19851aeac5b52fa56bc3b22dc6c01528a51e90fbe7dc49f327c6141d900a6b6a638c37c033028fd3456 SHA512 b0d95d1df1e25bed34bc43a1f1794915854b88db640c5547446b48b49dd7de338a15a861d06be7cc20107cae1db2034a0dc200896ec0fe51917455fb014acb93
+EBUILD elfio-3.12.ebuild 764 BLAKE2B 2eaea55f32a41c500c43c9bb78b87dc71abec532d90a8edae103f0833e35137506cbf54e082cc758b5be19957bf477a9eeca9c121c327149898be9270e514a8b SHA512 5b6c2fa317afca22c78ad1a6829397e96a4f018937f1bddebe5ca0fc61164fede6c3aeeecbbd6f6ad37e1d483a0615894a08254358a32485d82d2ff2398e3255
MISC metadata.xml 317 BLAKE2B 4b62079a213f05ca0fce72e62582010a9c82e11e714347c6753a1919bb8586896cef8afa5c378ffb00a5427aea6219fe7d78cc3572e214c3b2e8b09507ca685d SHA512 d550d765b42e68da41164297145ed8534b6bfb8f7976e6df57f76fb0fc8558262f010d988b66ea368d45e7c4bbbc879f6b91abba21c3f14871605e39589e5047
diff --git a/dev-cpp/elfio/elfio-3.12.ebuild b/dev-cpp/elfio/elfio-3.12.ebuild
index eb255680b9c4..621f3eda2dc0 100644
--- a/dev-cpp/elfio/elfio-3.12.ebuild
+++ b/dev-cpp/elfio/elfio-3.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,11 +20,11 @@ DEPEND="test? ( dev-cpp/gtest )"
PATCHES=(
"${FILESDIR}"/${PN}-3.12-gnuinstalldirs-docdir.patch
+ "${FILESDIR}"/${PN}-3.12-gcc15.patch
)
src_configure() {
local mycmakeargs=(
- -DFETCHCONTENT_FULLY_DISCONNECTED=ON
-DELFIO_BUILD_TESTS=$(usex test)
)
diff --git a/dev-cpp/elfio/files/elfio-3.12-gcc15.patch b/dev-cpp/elfio/files/elfio-3.12-gcc15.patch
new file mode 100644
index 000000000000..805da1564891
--- /dev/null
+++ b/dev-cpp/elfio/files/elfio-3.12-gcc15.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/937460
+
+From 34d2c64237bb40f09879e7421db120e50e7e2923 Mon Sep 17 00:00:00 2001
+From: Orion Poplawski <orion@nwra.com>
+Date: Fri, 31 Jan 2025 20:22:26 -0700
+Subject: [PATCH] Add missing #include <stdint.h> for gcc 15
+
+---
+ elfio/elf_types.hpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/elfio/elf_types.hpp b/elfio/elf_types.hpp
+index 3a6850a..cd9aa7f 100644
+--- a/elfio/elf_types.hpp
++++ b/elfio/elf_types.hpp
+@@ -23,6 +23,8 @@ THE SOFTWARE.
+ #ifndef ELFTYPES_H
+ #define ELFTYPES_H
+
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ namespace ELFIO {
+ #endif