summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin13064 -> 13065 bytes
-rw-r--r--dev-cpp/asio/Manifest2
-rw-r--r--dev-cpp/asio/asio-1.26.0.ebuild64
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 10f3a9234416..eed7b55ba3df 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 4b1e3ecba456..520e078dc8e2 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,5 @@
DIST asio-1.24.0.tar.bz2 3150924 BLAKE2B 4c9b913452fd4288684020ca58b48e22745a39c6a0d682ba84ff561b94c695dc6f5203ed06817f4dd0b9098ea3012578f7c6b2f251b3857e660b0c222dbc003e SHA512 c877968229bc5c4c21156b2bbb9775c7b11c3878cd62e8df3afaa70b2f221c59c6e4fa425cfb028cd170f9453ac1c32c5229f89437b13ac39142e4b52304c820
+DIST asio-1.26.0.tar.bz2 3201833 BLAKE2B a42297b448423984143ff8e6a1dcc965f0ef0582e1609c1d51331f1e3d86c96ef9caf9daad36222104f95210ee84a3a59c50b28cb8985b6387a30db690d91b27 SHA512 3e41f71a4e0c6928ec9b9fa1b43b5db3eff21d330de6f6def60deacda79632ded3c4d2b2ffe1ae3fe756ba73e37fac30ecd76a76e1e52067e337cd0e7c9260e7
EBUILD asio-1.24.0.ebuild 1251 BLAKE2B 90792c9116e9d7833904e9038eb808bf1d8cda71740cacea4a628434fd518ed5959acdc7b46a739c13789b2ce87edc4b8c141a8f3d300c95dd6e60bde7557034 SHA512 c718366902f530001d13d4cf7c7c8b5ba98a26bdd351ea90ea0de54a357a48db9ba725c16907632aa4e5aef060cef8f9605a9e0f971c6261ee7ef6a5260dd13e
+EBUILD asio-1.26.0.ebuild 1257 BLAKE2B 2e4f906965749ff9f66865e88e186707619da66f001b25d4dd4756ed1f408c2c8190fb6d341442e198c274c72c002c7f429d5dad4fa0986bb53029c4d03df013 SHA512 b47cbbef693837cf8d498160b6c02e3c82687c3b0ce25c5636807d733a52e0cd2d00f78920dec1d227a3605f9904c90475f3f938d34652be1981db9f016b12e8
MISC metadata.xml 487 BLAKE2B 57785b73f498590d36241612367eda9036cc4ce85baa6c59e45a4c4f0b696f24f7bbe012eef33dd2e29a9c82fad82f75639e55f9c7a6e2e001b7ab48b65787cc SHA512 4a4f9713ea7274f730707dda0f2de0e0c19e50166466c0b8c3e5053e44fa5df02866235cfd97ebeaff15271cce662f1ae19383c0023813d429eded937d9b9cfb
diff --git a/dev-cpp/asio/asio-1.26.0.ebuild b/dev-cpp/asio/asio-1.26.0.ebuild
new file mode 100644
index 000000000000..640c6e0e2743
--- /dev/null
+++ b/dev-cpp/asio/asio-1.26.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_configure() {
+ # By default it puts .pc to libdir
+ econf --with-pkgconfigdir="${EPREFIX}/usr/share/pkgconfig"
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ # Make links to the example .cpp files work
+ # https://bugs.gentoo.org/828648
+ if use doc; then
+ dosym ../examples /usr/share/doc/${PF}/src/examples
+ fi
+ fi
+}