summaryrefslogtreecommitdiff
path: root/dev-cpp/websocketpp/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/websocketpp/files')
-rw-r--r--dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch24
-rw-r--r--dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch25
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch
new file mode 100644
index 000000000000..28f4361f35c1
--- /dev/null
+++ b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-boost_find_component.patch
@@ -0,0 +1,24 @@
+From 36b73da8958927f975b3d01a062aa6c0e149d97f Mon Sep 17 00:00:00 2001
+From: Peter Thorson <git@zaphoyd.com>
+Date: Mon, 27 Apr 2020 10:34:06 -0500
+Subject: [PATCH] [cmake] Remove quotes that was making it hard for cmake to
+ find newer boost versions. fixes #855
+
+---
+ CMakeLists.txt | 2 +-
+ changelog.md | 3 +++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3e9c80e84..ffcd8583b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -215,7 +215,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
+ set (Boost_USE_MULTITHREADED TRUE)
+ set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
+
+- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
++ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
+
+ if (Boost_FOUND)
+ # Boost is a project wide global dependency.
diff --git a/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch
new file mode 100644
index 000000000000..2937ba71aced
--- /dev/null
+++ b/dev-cpp/websocketpp/files/websocketpp-0.8.2-fix-clang.patch
@@ -0,0 +1,25 @@
+From 2c355d9ef0f3ed73fa96d0c6c31293086df36d74 Mon Sep 17 00:00:00 2001
+From: Peter Thorson <git@zaphoyd.com>
+Date: Sun, 19 Apr 2020 22:33:24 -0500
+Subject: [PATCH] Fix typo in CMakeLists.txt that caused CXX_FLAGS to be
+ improperly quoted. Removed unnecessary hardcoded dependency on libc++ for
+ clang. fixes #859
+
+---
+ CMakeLists.txt | 2 +-
+ changelog.md | 3 +++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dcf90d1c8..3e9c80e84 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -152,7 +152,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
+ endif()
+ set (WEBSOCKETPP_PLATFORM_TLS_LIBS ssl crypto)
+ set (WEBSOCKETPP_BOOST_LIBS system thread)
+- set (CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-std=c++0x -stdlib=libc++") # todo: is libc++ really needed here?
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
+ if (NOT APPLE)
+ add_definitions (-DNDEBUG -Wall -Wno-padded) # todo: should we use CMAKE_C_FLAGS for these?
+ endif ()