summaryrefslogtreecommitdiff
path: root/dev-cpp/waylandpp/waylandpp-0.2.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/waylandpp/waylandpp-0.2.8.ebuild')
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.8.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.8.ebuild
new file mode 100644
index 000000000000..6fda559666cb
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.2.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+ >=dev-libs/pugixml-1.9-r1
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ )
+
+ cmake_src_configure
+}