summaryrefslogtreecommitdiff
path: root/dev-cpp/valijson/valijson-0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/valijson/valijson-0.7.ebuild')
-rw-r--r--dev-cpp/valijson/valijson-0.7.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-cpp/valijson/valijson-0.7.ebuild b/dev-cpp/valijson/valijson-0.7.ebuild
deleted file mode 100644
index ca723120f1e0..000000000000
--- a/dev-cpp/valijson/valijson-0.7.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Header-only C++ library for JSON Schema validation"
-HOMEPAGE="https://github.com/tristanpenman/valijson"
-SRC_URI="https://github.com/tristanpenman/valijson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -Dvalijson_BUILD_TESTS=$(usex test)
- )
-
- if use test; then
- # Fix relative paths to test data
- sed -i -e "s:../tests/data/documents/:../${P}/tests/data/documents/:" tests/test_adapter_comparison.cpp || die
- sed -i -e "s:../tests/data:../${P}/tests/data:" tests/test_validation_errors.cpp || die
- sed -i -e "s:../thirdparty/:../${P}/thirdparty/:" -e "s:../doc/schema/:../${P}/doc/schema/:" tests/test_validator.cpp || die
- fi
-
- # -Werror is too aggressive due to false positives with gcc-12, see bug #866153
- sed -i -e 's/-Werror//g' ../${P}/CMakeLists.txt || die
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- ./test_suite || die
-}
-
-src_install() {
- # there is no target for installing headers, so do it manually
- doheader -r include/*
-}