summaryrefslogtreecommitdiff
path: root/dev-cpp/pstreams/pstreams-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/pstreams/pstreams-1.0.1.ebuild')
-rw-r--r--dev-cpp/pstreams/pstreams-1.0.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-cpp/pstreams/pstreams-1.0.1.ebuild b/dev-cpp/pstreams/pstreams-1.0.1.ebuild
deleted file mode 100644
index 9f2d12528d54..000000000000
--- a/dev-cpp/pstreams/pstreams-1.0.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="C++ wrapper for the POSIX.2 functions popen(3) and pclose(3)"
-HOMEPAGE="http://pstreams.sourceforge.net/"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- doc? ( mirror://sourceforge/${PN}/${PN}-docs-${PV}.tar.gz )"
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="doc"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-
-src_compile() {
- if use doc; then
- doxygen -u || die
- emake docs
- fi
-}
-
-src_test() {
- emake \
- CXX="$(tc-getCXX)" \
- CXXFLAGS="${CXXFLAGS}" \
- check
-}
-
-src_install() {
- doheader pstream.h
-
- dodoc AUTHORS ChangeLog README
-
- if use doc ; then
- docinto html
- dodoc -r "${WORKDIR}"/${PN}-docs-${PV}/*
- fi
-}