summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index ded1b4622890..727db8df498c 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -5,11 +5,13 @@ EAPI=7
inherit cmake
+# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
+TEST_VERSION="3.0.0"
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
SRC_URI="
https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
+ test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
S="${WORKDIR}/json-${PV}"
LICENSE="MIT"