summaryrefslogtreecommitdiff
path: root/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild')
-rw-r--r--dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild b/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
deleted file mode 100644
index 0f8a8f23a825..000000000000
--- a/dev-cpp/libmcpp/libmcpp-2.7.2-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MY_P=${P/lib/}
-
-DESCRIPTION="A portable C++ preprocessor"
-HOMEPAGE="http://mcpp.sourceforge.net"
-SRC_URI="mirror://sourceforge/mcpp/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 x86 ~x86-linux ~x64-macos"
-IUSE="static-libs"
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${PN}-2.7.2-fix-build-system.patch )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-mcpplib \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}