summaryrefslogtreecommitdiff
path: root/dev-cpp/libassa/libassa-3.5.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libassa/libassa-3.5.1-r2.ebuild')
-rw-r--r--dev-cpp/libassa/libassa-3.5.1-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/libassa/libassa-3.5.1-r2.ebuild b/dev-cpp/libassa/libassa-3.5.1-r2.ebuild
new file mode 100644
index 000000000000..8d46aa4035ef
--- /dev/null
+++ b/dev-cpp/libassa/libassa-3.5.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A networking library based on Adaptive Communication Patterns"
+HOMEPAGE="http://libassa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch
+ "${FILESDIR}"/${PN}-3.5.1-gcc47.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}