summaryrefslogtreecommitdiff
path: root/dev-cpp/fb303
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/fb303')
-rw-r--r--dev-cpp/fb303/Manifest3
-rw-r--r--dev-cpp/fb303/fb303-2024.11.04.00.ebuild51
-rw-r--r--dev-cpp/fb303/metadata.xml15
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-cpp/fb303/Manifest b/dev-cpp/fb303/Manifest
new file mode 100644
index 000000000000..18caeb804f0f
--- /dev/null
+++ b/dev-cpp/fb303/Manifest
@@ -0,0 +1,3 @@
+DIST fb303-2024.11.04.00.gh.tar.gz 256825 BLAKE2B a7cb9b56f38f0a8f20a860b4b288f37cb59315242b50ac757bcd472e0310491a575149b2580a67a837a52badaf7ca4b72a769293d248830f90a0cf48f351835a SHA512 4ec54931f23267197e74cc0c3a0dd500f443221d5c4a6bb6a4d707feb6fbc377ef6c16f8fa94f2162e2c0a192fce01016f249890f7384a6c042b5f94b657dc11
+EBUILD fb303-2024.11.04.00.ebuild 1044 BLAKE2B 4a488791b63463316ff4dad57d712b5b8efcf85cc133aa106561ddb120c0c0914f080922b72a1a44f9a380f4f26ab9774ccdb93f8de2bb7a30828c2185686ca7 SHA512 26301249cb27737b2bb60a46ba75f64a82d978f6da434b3edfc92bc7dac598d0d68886ba916d269caa65c8771e962887641199ef8a183ae1b5577c3c7528c637
+MISC metadata.xml 472 BLAKE2B a1dd333968267401d3ca1b8d71b718298dc48591707be5b6c45f1ce20fb2e8097963cb643acae18513ccc8aea3f70ecc2003170e47929ed9533b7b4a909d3762 SHA512 918f05c46aaf18203740925dbb8d352e45b02f884f0c836dc5ebf5bde8dd8c5d333b305792638bc805fcc35590af8d2338d12f7c8e9d18b7b1a6eb0665511704
diff --git a/dev-cpp/fb303/fb303-2024.11.04.00.ebuild b/dev-cpp/fb303/fb303-2024.11.04.00.ebuild
new file mode 100644
index 000000000000..915f3bcf8459
--- /dev/null
+++ b/dev-cpp/fb303/fb303-2024.11.04.00.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="Core set of Thrift functions querying stats and other information from a service"
+HOMEPAGE="https://github.com/facebook/fb303"
+SRC_URI="https://github.com/facebook/fb303/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# See https://github.com/facebook/fb303/issues/61
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-cpp/fbthrift-${PV}:=
+ ~dev-cpp/fizz-${PV}:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ ~dev-cpp/wangle-${PV}:=
+ dev-libs/libfmt:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/fb303/metadata.xml b/dev-cpp/fb303/metadata.xml
new file mode 100644
index 000000000000..9ccd45cef63b
--- /dev/null
+++ b/dev-cpp/fb303/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sin-ack@protonmail.com</email>
+ <name>sin-ack</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebook/fb303</remote-id>
+ </upstream>
+</pkgmetadata>