summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-taskflow/cpp-taskflow-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cpp-taskflow/cpp-taskflow-3.0.0.ebuild')
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-3.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.0.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-3.0.0.ebuild
new file mode 100644
index 000000000000..ee708046e377
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${P}-gnuinstalldir.patch )
+
+S="${WORKDIR}/taskflow-${PV}"
+HTML_DOCS=( docs/. )
+
+src_configure() {
+ # TODO: enable CUDA via USE flag
+ local mycmakeargs=(
+ -DTF_BUILD_CUDA=OFF
+ -DTF_BUILD_EXAMPLES=$(usex examples)
+ -DTF_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}