summaryrefslogtreecommitdiff
path: root/dev-cpp/benchmark/benchmark-1.5.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.5.6.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.5.6.ebuild b/dev-cpp/benchmark/benchmark-1.5.6.ebuild
new file mode 100644
index 000000000000..f0322cb58a4e
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.5.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+IUSE="debug test"
+
+RESTRICT="!test? ( test )"
+
+# Version not in the tree yet
+#BDEPEND="test? ( >=dev-cpp/gtest-1.11.0 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.6-system_testdeps.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ )
+
+ use debug || append-cppflags -DNDEBUG
+
+ cmake_src_configure
+}