summaryrefslogtreecommitdiff
path: root/dev-cpp/argparse/argparse-2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/argparse/argparse-2.6.ebuild')
-rw-r--r--dev-cpp/argparse/argparse-2.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/argparse/argparse-2.6.ebuild b/dev-cpp/argparse/argparse-2.6.ebuild
new file mode 100644
index 000000000000..e273fd49b506
--- /dev/null
+++ b/dev-cpp/argparse/argparse-2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Argument Parser for Modern C++"
+HOMEPAGE="https://github.com/p-ranav/argparse"
+SRC_URI="https://github.com/p-ranav/argparse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DARGPARSE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test || die
+ ./tests || die
+}