summaryrefslogtreecommitdiff
path: root/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild')
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
index 37ace99caa9e..9f123f017901 100644
--- a/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
+++ b/dev-cpp/antlr-cpp/antlr-cpp-4.7.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="The ANTLR 4 C++ Runtime"
HOMEPAGE="https://www.antlr.org/"
@@ -12,7 +12,7 @@ LICENSE="BSD"
SLOT="4"
KEYWORDS="amd64 ~arm ~ppc x86"
-DEPEND="app-arch/zip"
+DEPEND="app-arch/unzip"
S="${WORKDIR}"
@@ -23,5 +23,5 @@ src_prepare() {
sed -i -e "s#share/doc/libantlr4#share/doc/${P}#g" \
"${S}"/CMakeLists.txt || die "failed sed"
- cmake-utils_src_prepare
+ cmake_src_prepare
}