summaryrefslogtreecommitdiff
path: root/dev-build
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/Manifest.gzbin7718 -> 7716 bytes
-rw-r--r--dev-build/gyp/Manifest3
-rw-r--r--dev-build/gyp/gyp-20200512145953-r1.ebuild67
-rw-r--r--dev-build/gyp/gyp-99999999999999.ebuild48
4 files changed, 100 insertions, 18 deletions
diff --git a/dev-build/Manifest.gz b/dev-build/Manifest.gz
index 80523f1429af..7eef93b96428 100644
--- a/dev-build/Manifest.gz
+++ b/dev-build/Manifest.gz
Binary files differ
diff --git a/dev-build/gyp/Manifest b/dev-build/gyp/Manifest
index b374e9a4e5f4..cc684c5f0d59 100644
--- a/dev-build/gyp/Manifest
+++ b/dev-build/gyp/Manifest
@@ -1,4 +1,5 @@
DIST gyp-20200512145953.tar.xz 443884 BLAKE2B 74ff269e3e8aa51e6b34f795892f6e8922d098a81b4d855619520d3d366e79b611931cddf4ee2ec60a7e040af11ac8eba7582ad10e24de627df5a4aa4eba6474 SHA512 35bf2af22f2e632b3d6e546e5017df8effd0c7ad80beed9b95ed1e2f294d70215889bc6a0147506461254e951d70189dc48824af10a6620e996945d2cf5586ee
+EBUILD gyp-20200512145953-r1.ebuild 1809 BLAKE2B 0a0e05c2b96ba26729cae49b3aa434d8eba714c41604688a348968db659e17da0ff574bcc1f977ecdac6ee98ec6f72bdfe4dd20372f2eee14279f5be64aca0bf SHA512 084946693b46aff63e4b4b957de7dec8253e315d24c480b662713a1e49d456c4a067bb29ab43610552003fd025d62282aff82a1530c9a56958c8b23b61f28c69
EBUILD gyp-20200512145953.ebuild 1517 BLAKE2B 4883fd2a5834b8f1067f4dda8e5098bb6fbe7b4836b5a7dce1480211554277a420c1517c9368b52e86ae11f8d407f9c696b2a23552cc4b25219c8a4bdc772190 SHA512 95332b6b3b5cc8d727ab12d67dfb3d26836e4275ffc3be3f3f2bca6d9cbbc4ba8b03b7a8e16f8b8fbe9e1866163c2320ed862b167f26dd2ee1d0a4e73f70e2e5
-EBUILD gyp-99999999999999.ebuild 1520 BLAKE2B eb58d0943903a263a545494d627be191f7edef9c580a686eb0f2b44a471f8dfe0cd14b68b8daaa7d85e4ed70fa3ec3ddb08c748e01bf033d1ce01e325eb0956f SHA512 042df5b7ac97a0350b1f316f9a466a52864db53a3bac5d5a207419fc979aee9d26eacb7ed0c9d7bdee127cb0152100bc5fb933cd722aedc3eb0bc0e15420d30c
+EBUILD gyp-99999999999999.ebuild 1809 BLAKE2B 0a0e05c2b96ba26729cae49b3aa434d8eba714c41604688a348968db659e17da0ff574bcc1f977ecdac6ee98ec6f72bdfe4dd20372f2eee14279f5be64aca0bf SHA512 084946693b46aff63e4b4b957de7dec8253e315d24c480b662713a1e49d456c4a067bb29ab43610552003fd025d62282aff82a1530c9a56958c8b23b61f28c69
MISC metadata.xml 235 BLAKE2B a3e5a3109b59e3f97ef14f8d55ba13b16dc5371a1b7d6f238230aa4494db32dd4a42e3ee012ec8b18fae394feb2b1b56882bc70504aa7c6b969c1b20140f0ece SHA512 7c4e5f5dea465e45c662f5f53513626088aff514e1326593426af227d77e63d8a00d8af05aa208881a399f83dd41e73cd2ef81c8b7f275a2fa891f295231d67c
diff --git a/dev-build/gyp/gyp-20200512145953-r1.ebuild b/dev-build/gyp/gyp-20200512145953-r1.ebuild
new file mode 100644
index 000000000000..f46a15970ed9
--- /dev/null
+++ b/dev-build/gyp/gyp-20200512145953-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2017-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo python-single-r1
+
+DESCRIPTION="GYP (Generate Your Projects) meta-build system"
+HOMEPAGE="https://gyp.gsrc.io/ https://chromium.googlesource.com/external/gyp"
+
+if [[ ${PV} == 99999999999999 ]]; then
+ EGIT_REPO_URI="https://chromium.googlesource.com/external/gyp"
+ inherit git-r3
+else
+ SRC_URI="https://home.apache.org/~arfrever/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Needs review after updating to a newer commit
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed \
+ -e "s/import collections/import collections.abc/" \
+ -e "s/collections\.MutableSet/collections.abc.MutableSet/" \
+ -i pylib/gyp/common.py || die
+ sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
+ sed \
+ -e "s/import collections/import collections.abc/" \
+ -e "s/collections\.Iterable/collections.abc.Iterable/" \
+ -i pylib/gyp/msvs_emulation.py || die
+ sed \
+ -e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
+ -e "s/conditions is ()/conditions == ()/" \
+ -i test/lib/TestCmd.py || die
+}
+
+src_compile() {
+ edo ${EPYTHON} setup.py build
+}
+
+src_test() {
+ # More errors with DeprecationWarnings enabled.
+ local -x PYTHONWARNINGS=""
+
+ edo "${PYTHON}" gyptest.py --all --verbose
+}
+
+src_install() {
+ edo ${EPYTHON} setup.py install --prefix="${EPREFIX}/usr" --root="${D}"
+ python_optimize
+ einstalldocs
+}
diff --git a/dev-build/gyp/gyp-99999999999999.ebuild b/dev-build/gyp/gyp-99999999999999.ebuild
index d0cfc3580646..f46a15970ed9 100644
--- a/dev-build/gyp/gyp-99999999999999.ebuild
+++ b/dev-build/gyp/gyp-99999999999999.ebuild
@@ -1,42 +1,46 @@
-# Copyright 2017-2024 Gentoo Authors
+# Copyright 2017-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_SINGLE_IMPL="1"
+EAPI=8
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo python-single-r1
DESCRIPTION="GYP (Generate Your Projects) meta-build system"
HOMEPAGE="https://gyp.gsrc.io/ https://chromium.googlesource.com/external/gyp"
-if [[ "${PV}" == "99999999999999" ]]; then
+if [[ ${PV} == 99999999999999 ]]; then
EGIT_REPO_URI="https://chromium.googlesource.com/external/gyp"
inherit git-r3
else
SRC_URI="https://home.apache.org/~arfrever/distfiles/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 ~loong ~ppc64 x86"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Needs review after updating to a newer commit
+RESTRICT="test"
-BDEPEND=""
-DEPEND=""
-RDEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+"
-python_prepare_all() {
- distutils-r1_python_prepare_all
+src_prepare() {
+ default
sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
sed \
- -e "s/^import collections/import collections.abc/" \
+ -e "s/import collections/import collections.abc/" \
-e "s/collections\.MutableSet/collections.abc.MutableSet/" \
-i pylib/gyp/common.py || die
sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
sed \
- -e "s/^import collections/import collections.abc/" \
+ -e "s/import collections/import collections.abc/" \
-e "s/collections\.Iterable/collections.abc.Iterable/" \
-i pylib/gyp/msvs_emulation.py || die
sed \
@@ -45,9 +49,19 @@ python_prepare_all() {
-i test/lib/TestCmd.py || die
}
-python_test() {
+src_compile() {
+ edo ${EPYTHON} setup.py build
+}
+
+src_test() {
# More errors with DeprecationWarnings enabled.
local -x PYTHONWARNINGS=""
- "${PYTHON}" gyptest.py --all --verbose
+ edo "${PYTHON}" gyptest.py --all --verbose
+}
+
+src_install() {
+ edo ${EPYTHON} setup.py install --prefix="${EPREFIX}/usr" --root="${D}"
+ python_optimize
+ einstalldocs
}