summaryrefslogtreecommitdiff
path: root/dev-build/rocm-cmake/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/rocm-cmake/files')
-rw-r--r--dev-build/rocm-cmake/files/rocm-cmake-6.1.1-license.patch12
-rw-r--r--dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch25
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-license.patch b/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-license.patch
new file mode 100644
index 000000000000..f8770b345f85
--- /dev/null
+++ b/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-license.patch
@@ -0,0 +1,12 @@
+This is not needed. Gentoo will collect license files into
+the documentation directory in ebuild.
+--- a/share/rocmcmakebuildtools/cmake/ROCMCreatePackage.cmake
++++ b/share/rocmcmakebuildtools/cmake/ROCMCreatePackage.cmake
+@@ -409,7 +409,6 @@ macro(rocm_create_package)
+ if(PARSE_PTH)
+ rocm_parse_python_syspath(${LIB_DIR} ${PARSE_NAME})
+ endif()
+- rocm_setup_license(${PARSE_HEADER_ONLY})
+ if(PARSE_COMPONENTS)
+ rocm_set_comp_cpackvar(PARSE_HEADER_ONLY "${PARSE_COMPONENTS}")
+ endif()
diff --git a/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch b/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch
new file mode 100644
index 000000000000..73030e7b9b20
--- /dev/null
+++ b/dev-build/rocm-cmake/files/rocm-cmake-6.1.1-no-rocmchecks-warnings.patch
@@ -0,0 +1,25 @@
+Gentoo uses cmake -C <...>/gentoo_common_config.cmake approach to set toolchain variables.
+There is nothing wrong there, so there is no need to print huge ROCMChecks warnings.
+--- a/share/rocmcmakebuildtools/cmake/ROCMChecks.cmake
++++ b/share/rocmcmakebuildtools/cmake/ROCMChecks.cmake
+@@ -34,20 +34,6 @@ function(rocm_check_toolchain_var var access value list_file)
+ elseif("${base}" MATCHES ".*/CMakeFiles/${CMAKE_VERSION}$")
+ set(cmake_module On)
+ endif()
+- if(NOT cmake_module)
+- message( "
+-*******************************************************************************
+-*------------------------------- ${message_title} --------------------------*
+- Options and properties should be set on a cmake target where possible. The
+- variable '${var}' may be set by the cmake toolchain, either by
+- calling 'cmake -D${var}=\"${value}\"'
+- or set in a toolchain file and added with
+- 'cmake -DCMAKE_TOOLCHAIN_FILE=<toolchain-file>'. ROCMChecks now calling:")
+- message(${message_type} "'${var}' is set at ${CMAKE_CURRENT_LIST_DIR}/CMakeLists.txt:<line#> shown below:")
+- message( "*-----------------------------------------------------------------------------*
+-*******************************************************************************
+-")
+- endif()
+ endif()
+ endfunction()
+ if(UNIX AND (ROCM_WARN_TOOLCHAIN_VAR OR ROCM_ERROR_TOOLCHAIN_VAR))