summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31933 -> 31933 bytes
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20210828.ebuild42
-rw-r--r--app-vim/tt2-syntax/Manifest2
-rw-r--r--app-vim/tt2-syntax/tt2-syntax-1.13-r1.ebuild4
5 files changed, 47 insertions, 3 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 566b3cbb2b3a..4b33ac9a3592 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 298f9a166727..97a3369dafac 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20210716.tar.bz2 18872 BLAKE2B faef2f356331c8560cb8e8014ad1a32a299f94fe8d05be499955cb78f1537f85abe44864b782df34244c3e606443b2146bd58a55047b23d327a548a436e818dc SHA512 f1a374fb5cf05563ea8cafa2209c9e8ba62bc072cac99202f486c3f7412cbb63432a33830e285ba706f8f73ee7f7bfd4e0b30bfad6feee1643e862b86495b82e
+DIST gentoo-syntax-20210828.tar.bz2 18872 BLAKE2B bd3e152718b921aef8ce93e2d3e66d6195ab01801ea60987f62f9cb541fb726c2d552b6ec341943c1ca0e0cc1419c1cb75266e653b8bc958c8103855688f3d54 SHA512 e148c42b3e3281780d4f23ff1e464ba3c8404b3a4ba566a1a685c8364b6dd174830b489d5c7b561c3e30375fd9f510cfbf56d92f81c3f8fec8ab792ab48aa62a
EBUILD gentoo-syntax-20210716.ebuild 1238 BLAKE2B 3916495228ba1ec18105d683abab3120935f1f4cef4c5696611369fcaf972d359659b671ba0ff4861550c25502cf16ec7124289f179bcc1ece7b39f5dc72c4eb SHA512 ee61a219cb0be58be48e458fd9955dd97ee6aa2358c31951b42a4168285969f8b31e507ff00b73b43484649c5a2225e6af34d24e6e4f8c078f075de4dbc4b2e4
+EBUILD gentoo-syntax-20210828.ebuild 1245 BLAKE2B 4de7b82e15d0e8e0716fa3b419297d3ce15bbe12d7fc8007e231bc09cd3d9236af4c5d08e7c6dec0c1058150eec401c37a24d3b5bade0319947617db9d358bb6 SHA512 9a14cb1d43d22cde53c0f7c9598bfdbb2cd1f0417bc69b604823f595b6f1a59a95aeb47cd61a68707abe8412a2ca44d71a67a51c731d7e083b2f4cab299e6584
EBUILD gentoo-syntax-99999999.ebuild 1084 BLAKE2B cbe1d6aa8eca271a997dec67ba8ba3725e3c50d97ff2f1f18c169bd3ea84ed568390ffef00742d20748dec2ec9b98468a119fc10b62bd55cd05e0506227e58cd SHA512 e59ceccbaaeb0947a66c079380269acd431d9694a20b851c13d5772a610306db1ddb04e8d8173ad5b84723077dae034a60ac7d53ba448ae00e816fdc03dc9f61
MISC metadata.xml 585 BLAKE2B 7f904a47ab12627ae911fa96328c50af2cb16b785fa0b60cace8a586b17de344625b749b52ef6b89b4751aba74bc25339b3e6c9105ee47d15b5c6539b5d902ee SHA512 dfed3c4c2b3697b00896591dc4b23eb6433ce77b4aaaab05119ca0b11e355e321b2cf5f0ab5e0b2dd075abd1a266908e07b80846a11d50f17155d7ab35e6c742
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20210828.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20210828.ebuild
new file mode 100644
index 000000000000..72f25ef766b6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20210828.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}
diff --git a/app-vim/tt2-syntax/Manifest b/app-vim/tt2-syntax/Manifest
index c9daf0ea4b70..7d2e92eb930b 100644
--- a/app-vim/tt2-syntax/Manifest
+++ b/app-vim/tt2-syntax/Manifest
@@ -1,3 +1,3 @@
DIST tt2-syntax-1.13.tar.bz2 2991 BLAKE2B 07efcef9b28b8c44ff55d970dec2a9bff73c6e67adc3f03e6c09beca5552599b87150af08f82211f48ff79fb595f5324c60d1917a5f0378e769643b80c19b503 SHA512 0e7f5ca2b5dd53598778bb85a76fbb8be52ce789221342cb5ab51a5084c7d679b8b2f5cee4f8f05db9648a5828471eeba3d0367959f09d280d9c098a9c21e52e
-EBUILD tt2-syntax-1.13-r1.ebuild 449 BLAKE2B 6459dfbbd1398b1fa5e3d045df78e8c87253b8b83d91021af1d96583bc6ea16a83c3d4d2942fc3c7f1b8c2fcbbb17b8e1681b3f445fde52eaf9454004b62e681 SHA512 7189454b375c2f3ac4c4bc82dea48ba323a4d6c8b09bc30beab9c53e7177d041da881edb9a192f5e6c75760bc41ebac6232333dc91add73a8e9f014770d23980
+EBUILD tt2-syntax-1.13-r1.ebuild 542 BLAKE2B 56c05c4ec5c08ea6581b4c8617e5f78b009abdc32c5908fd5d00438b8f21c934568ec5b3c7915ae6e78b40543e94c011a5c2362441cbf3319aeb2913b9aad374 SHA512 320bb453ff884df10ef5d3ac3e6f7a04e867eaa2fd81f1d3c0090a88632e929e4d7752a8a66f61a698b55548342465e3e29346bcfae9e5fa5d23654ed31f93a3
MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/tt2-syntax/tt2-syntax-1.13-r1.ebuild b/app-vim/tt2-syntax/tt2-syntax-1.13-r1.ebuild
index 7dd20ae4fcd5..3b06797c2685 100644
--- a/app-vim/tt2-syntax/tt2-syntax-1.13-r1.ebuild
+++ b/app-vim/tt2-syntax/tt2-syntax-1.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ inherit vim-plugin
DESCRIPTION="vim plugin: syntax highlighting for perl module Template-Toolkit"
HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=830"
LICENSE="vim"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~x64-macos"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
VIM_PLUGIN_HELPTEXT=\