summaryrefslogtreecommitdiff
path: root/app-vim/vim-r/vim-r-1.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vim-r/vim-r-1.2.6.ebuild')
-rw-r--r--app-vim/vim-r/vim-r-1.2.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/vim-r/vim-r-1.2.6.ebuild b/app-vim/vim-r/vim-r-1.2.6.ebuild
new file mode 100644
index 000000000000..df967fc39ce9
--- /dev/null
+++ b/app-vim/vim-r/vim-r-1.2.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: integrate vim with R"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2628"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/R"
+
+VIM_PLUGIN_HELPFILES="r-plugin.txt"
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "This plugin requires the vimcom R package to be installed,"
+ elog "see https://github.com/jalvesaq/VimCom for instructions."
+ fi
+}