summaryrefslogtreecommitdiff
path: root/app-vim/vim-go
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vim-go')
-rw-r--r--app-vim/vim-go/Manifest3
-rw-r--r--app-vim/vim-go/metadata.xml11
-rw-r--r--app-vim/vim-go/vim-go-1.13.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/vim-go/Manifest b/app-vim/vim-go/Manifest
new file mode 100644
index 000000000000..bcfa9a4e40cd
--- /dev/null
+++ b/app-vim/vim-go/Manifest
@@ -0,0 +1,3 @@
+DIST vim-go-1.13.zip 900566 SHA256 b4a6212becad775f90dedcb8045b04bf691f32c258c1fead68d5fbb7b775b463 SHA512 3a1818c126c6ab01cd6993336c9e87f88357375b5252e0aeed434dccd0514cbcb1b7c96dce2aaf8f8c2e21909a17bf4bbb39a386ee1f7049b50a85ed9c635817 WHIRLPOOL 0c92fe8f0f685401a9014124a0fb7341b7891dc5346b5af50124a5d2435614d11ed9d24922e0d5fe4cbfe0045ee0539769b3592ff5a0fdecf0f260a090e7b28d
+EBUILD vim-go-1.13.ebuild 581 SHA256 d38557282d9ca1fa81bdb185f139a5caa06b46e3b506cedab7dedd094edb79cf SHA512 39be06222c2466c2fee043542a471fd2e75b237c276c9126a63024fe2ac94f29f5ee0b08fe4afcfde4902aa6b3f5f74aacf89cdcda6449d67e5789c5fb3c8349 WHIRLPOOL eae35cde204f1e76339f1635fc45469dffa9f6782d2d7259dced69f6c51eb693842635a74bcd9b0b4891931ee08afb63b8f869094f1b77dff6db304aeb3f59e9
+MISC metadata.xml 326 SHA256 648cc60fed079e73be22699873a0923c49a9f06dcd29c5282f8af475f172f7cc SHA512 0075500c50b5ad7cf5610fbc4bb71e3ee3d655bc089916371ee0d66731387a2268df98ed6d7fcad6e70db28d6852b48c2e6742e131b7c5d50fc7a9656807fc60 WHIRLPOOL bd244d65f5f9eaa9dccc7a08f2fe382a8ac6e3b699af2dff0ef3361776abe70e054e67873ae4ff3f69b7d3c74b6c0475782ad6a8bb7b2d66e945e881c32070a8
diff --git a/app-vim/vim-go/metadata.xml b/app-vim/vim-go/metadata.xml
new file mode 100644
index 000000000000..a34620b83509
--- /dev/null
+++ b/app-vim/vim-go/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fatih/vim-go</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-go/vim-go-1.13.ebuild b/app-vim/vim-go/vim-go-1.13.ebuild
new file mode 100644
index 000000000000..2cffe300bf04
--- /dev/null
+++ b/app-vim/vim-go/vim-go-1.13.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="$PN"
+
+RESTRICT="test"
+
+src_compile() {
+ # safely skip `make test` triggered by `make` as it runs `go get` commands
+ # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+ :;
+}