summaryrefslogtreecommitdiff
path: root/app-vim/toggle
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/toggle')
-rw-r--r--app-vim/toggle/Manifest3
-rw-r--r--app-vim/toggle/metadata.xml8
-rw-r--r--app-vim/toggle/toggle-0.5-r1.ebuild16
3 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/toggle/Manifest b/app-vim/toggle/Manifest
new file mode 100644
index 000000000000..596610f63602
--- /dev/null
+++ b/app-vim/toggle/Manifest
@@ -0,0 +1,3 @@
+DIST toggle-0.5.tar.bz2 2790 BLAKE2B 365bffd541cfb40c7fea59049a4b7ef0caf0ef105a5ab382e740f3400b399715227d2d5433875583dfb31ac847c0a90d5436e6ef2aa1f8327eebc868484146c6 SHA512 bac60e8e09cb3d82ba1569c333174fa58596fcd009181a56feabeeba4590942805a14cf08c3ff3dc7920e8481d14b3bb659bb85ad1c8bd85ca66a5d491dae05c
+EBUILD toggle-0.5-r1.ebuild 444 BLAKE2B 330b74daf6af3acb0c9ba20655d675f469491042144ffc4bcf0a9a5b53260e74adbeff3ef4a570e23742a428b415fb14ecedee4b40cf3fcaa9e1185e5fe3cf14 SHA512 7afea8db84084cdbb61ae2fa565badc57453afad4adb0475c6eef5a23fcc4ed35c75da4e4c255c38288991febf7b440cbea348a666be43e4010bd97b2ffc51af
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/toggle/metadata.xml b/app-vim/toggle/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/toggle/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/toggle/toggle-0.5-r1.ebuild b/app-vim/toggle/toggle-0.5-r1.ebuild
new file mode 100644
index 000000000000..7e312a8c91de
--- /dev/null
+++ b/app-vim/toggle/toggle-0.5-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: quickly toggle boolean-type keywords"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=895"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin will toggle true/false, on/off, yes/no and so on when <C-T>
+is pressed."