summaryrefslogtreecommitdiff
path: root/app-vim/securemodelines
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/securemodelines')
-rw-r--r--app-vim/securemodelines/Manifest5
-rw-r--r--app-vim/securemodelines/metadata.xml17
-rw-r--r--app-vim/securemodelines/securemodelines-20140926.ebuild13
3 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/securemodelines/Manifest b/app-vim/securemodelines/Manifest
new file mode 100644
index 000000000000..e7d2e17c7b0a
--- /dev/null
+++ b/app-vim/securemodelines/Manifest
@@ -0,0 +1,5 @@
+DIST securemodelines-20140926.tar.bz2 1562 SHA256 57912489453596a3fceaffd8cc59c15cbf5f0b861a48add77e9c3f8649bb7947 SHA512 15a948781751998d832f445e7c3ad936e5c034fcc9936d977c5cf05215dd541a235fc066f7e774b151fac2afb2b0a59665d13f6f981cc59d4e1135f06f6cdc35 WHIRLPOOL e731692ef7c8bb25f3fb1bb936b94c140e57223f5904d3de685440bf1bba9b1ae0fc8bf2ca57cf2e732edb85233b4d15bf97bbbac550c02c621f62f4db007cc7
+EBUILD securemodelines-20140926.ebuild 526 SHA256 004102b8bd796b4ce957ff45c0690533f314c3a5d6924756dd33ba772d7b7512 SHA512 3933237c8661e98075bd6a71ffc1ab2d935299e83c6545a1b48960d0d2ca23f49365735e2d10332a168ce2786fbd1acbcea898b26fb9118d7cf8db917925216d WHIRLPOOL f076cbf07c62486e85ca8169f1dadab360c6d2f6bbaba29133f2231827699be4616419e55301b113271268d82054f78e8e007dd0880a46b604a15df1df3f8195
+MISC ChangeLog 2456 SHA256 4b36fb22efd52b0496cc2b62af46e25aa2190070c987befa16774674b075cf24 SHA512 beba20e7682ac3fd64c995af47909d82bf6b130be4ce3883598111e7c4217dc19c050ad98dfffb624e4678810b9f22f39ba41d305ef871b85cc60c4f2bc6aff6 WHIRLPOOL f9c6fda21f2f6bdad2e3238897f38bfc79a265828eaf5789669d62cef7135989b114865ebd788ea5207ef1c1775249fadc8f37f81732fd2a6c0845a438287aef
+MISC ChangeLog-2015 3240 SHA256 1ed9871b052f72469761cce29021e084009624ee9b3072af9908fae6de4eb13e SHA512 7ab7ded231e4941a2a98c6498e08b209e63c4160c64eed796f758c4e30b72728220ef00ded0b4a2f0a393a53a67c442c8892c271adfd802fc548d3844b768cca WHIRLPOOL 3f35f50fa6b52ade7afd592ca4b0e2614322e06b2be9138903c5044765c1439d63e31f6b94ef3ce1d40452577707f627422900e1eae356c4b2772440072494c4
+MISC metadata.xml 621 SHA256 a1dd4de3c7e3d71d2c079d07e6619e1602ad5498b4ce5472f7780daecf07a98a SHA512 ca9e3cce0633bacbb643201bc746e9c6397e9803c6b6c717c1a6e8fd2582e85e61f9fe7c8ea3ea575de6150ded96a0d26ce0fb6ac973884c37c19ce28ded9204 WHIRLPOOL 3768affa1ed22f92be2ab52aebe075afe0eba760385f6934df63a5450712056918843fd91f954a14ad575ffa63b1c88868688d21821654315110d0dc749764cb
diff --git a/app-vim/securemodelines/metadata.xml b/app-vim/securemodelines/metadata.xml
new file mode 100644
index 000000000000..419ac8208807
--- /dev/null
+++ b/app-vim/securemodelines/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Vim's internal modeline support allows all sorts of annoying and
+ potentially insecure options to be set. This script implements a much
+ more heavily restricted modeline parser that permits only user-specified
+ options to be set.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ciaranm/securemodelines</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/securemodelines/securemodelines-20140926.ebuild b/app-vim/securemodelines/securemodelines-20140926.ebuild
new file mode 100644
index 000000000000..dc217ecf0e85
--- /dev/null
+++ b/app-vim/securemodelines/securemodelines-20140926.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: secure, user-configurable modeline support"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1876 https://github.com/ciaranm/securemodelines"
+LICENSE="vim"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~sparc-fbsd ~x86-fbsd"
+
+VIM_PLUGIN_HELPTEXT="Make sure that you disable vim's builtin modeline support if you have
+enabled it in your .vimrc."