summaryrefslogtreecommitdiff
path: root/app-vim/pydiction/pydiction-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/pydiction/pydiction-1.2.3.ebuild')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3.ebuild b/app-vim/pydiction/pydiction-1.2.3.ebuild
new file mode 100644
index 000000000000..c4fae8228716
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+LICENSE="vim"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/python:*"
+
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ local pyfiles=( complete-dict pydiction.py )
+ doins "${pyfiles[@]}"
+ rm -v "${pyfiles[@]}" || die
+ vim-plugin_src_install
+}